summaryrefslogtreecommitdiff
path: root/vdr-vdrmanager/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'vdr-vdrmanager/debian/rules')
-rwxr-xr-xvdr-vdrmanager/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/vdr-vdrmanager/debian/rules b/vdr-vdrmanager/debian/rules
new file mode 100755
index 0000000..2e942e5
--- /dev/null
+++ b/vdr-vdrmanager/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+# include /usr/share/cdbs/1/rules/dpatch.mk
+
+DEB_INSTALL_CHANGELOGS_ALL = HISTORY
+
+MAKE_OPTIONS = DVBDIR=/usr VDRDIR=/usr/include/vdr LIBDIR=. \
+ LOCALEDIR=debian/tmp/usr/share/locale
+
+common-build-arch::
+ $(MAKE) all $(MAKE_OPTIONS)
+
+cleanbuilddir::
+ $(MAKE) -o .dependencies clean $(MAKE_OPTIONS)
+ rm -f libvdr-*.so.*
+
+common-binary-predeb-arch::
+ sh /usr/share/vdr-dev/dependencies.sh