summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorthlo <smarttv640@gmail.com>2014-04-25 16:57:31 +0200
committerthlo <smarttv640@gmail.com>2014-04-25 16:57:31 +0200
commitc35351510ccd0e99ac6cc8a0bb9384d24acc5571 (patch)
treec0c780190a25b137bdb2f1bc3af9cf596f5bc1e4 /debian
parenta02ff029d7dc91822c835b1ab9cdc42434a8caff (diff)
downloadvdr-plugin-smarttvweb-c35351510ccd0e99ac6cc8a0bb9384d24acc5571.tar.gz
vdr-plugin-smarttvweb-c35351510ccd0e99ac6cc8a0bb9384d24acc5571.tar.bz2
Debianize Plugin.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control14
-rw-r--r--debian/copyright32
-rw-r--r--debian/docs1
-rw-r--r--debian/install3
-rw-r--r--debian/postinst51
-rw-r--r--debian/postrm43
-rwxr-xr-xdebian/rules27
-rw-r--r--debian/source/format1
10 files changed, 177 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a8f677..3c32f23 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
-PACKAGE (VERSION) UNRELEASED; urgency=medium
+vdr-plugin-smarttvweb (0.9.9-1) unstable; urgency=low
- * Initial release. (Closes: #XXXXXX)
+ * Initial Debianize configuration
+ * Install configuration files
- -- thlo <thlo@teefax> Sat, 15 Jun 2013 15:44:43 +0200
+ -- T. Lohmar <smarttv640@gmail.com> Wed, 23 Apr 2014 10:03:18 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..45a4fb7
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+8
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..044d75a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: vdr-plugin-smarttvweb
+Section: video
+Priority: extra
+Maintainer: T. Lohmar <smarttv640@gmail.com>
+Build-Depends: debhelper (>= 8.0.0), pkg-config
+Standards-Version: 3.9.2
+Homepage: http://projects.vdr-developer.org/projects/plg-smarttvweb
+#Vcs-Git: git://git.debian.org/collab-maint/vdr-plugin-smarttvweb.git
+#Vcs-Browser: http://git.debian.org/?p=collab-maint/vdr-plugin-smarttvweb.git;a=summary
+
+Package: vdr-plugin-smarttvweb
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: VDR on SmartTV
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..8f3f57f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: http://dep.debian.net/deps/dep5
+Upstream-Name: vdr-plugin-smarttvweb
+Source: <url://example.com>
+
+Files: *
+Copyright: 2011-2014 T. Lohmar
+
+License: GPL-2.0+
+
+Files: debian/*
+Copyright: 2014 T. Lohmar <smarttv640@gmail.com>
+License: GPL-2.0+
+
+License: GPL-2.0+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..71dfd5b
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.txt
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..413efdb
--- /dev/null
+++ b/debian/install
@@ -0,0 +1,3 @@
+smarttvweb.conf var/lib/vdr/plugins/smarttvweb
+widget.conf var/lib/vdr/plugins/smarttvweb
+web/* var/lib/vdr/plugins/smarttvweb/web
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..7ed6d39
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,51 @@
+#!/bin/sh
+# postinst script for vdr-plugin-smarttvweb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+
+ # Create a log file, writable by the plugin
+ logfile=/var/log/smarttvweb/smarttvweb.log
+ if [ ! -f $logfile ]; then
+ touch $logfile
+ chmod 664 $logfile
+ chown -R root:vdr $(dirname $logfile)
+ fi
+
+ # Set ownership of web directory
+ chown -R vdr:vdr /var/lib/vdr/plugins/smarttvweb
+
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/postrm b/debian/postrm
new file mode 100644
index 0000000..4eaabc1
--- /dev/null
+++ b/debian/postrm
@@ -0,0 +1,43 @@
+#!/bin/sh
+# postrm script for vdr-plugin-smarttvweb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postrm> `remove'
+# * <postrm> `purge'
+# * <old-postrm> `upgrade' <new-version>
+# * <new-postrm> `failed-upgrade' <old-version>
+# * <new-postrm> `abort-install'
+# * <new-postrm> `abort-install' <old-version>
+# * <new-postrm> `abort-upgrade' <old-version>
+# * <disappearer's-postrm> `disappear' <overwriter>
+# <overwriter-version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ purge|abort-install|disappear)
+ # Remove log directory created in postinst
+ rm -rf /var/log/smarttvweb
+
+ ;;
+
+ remove|upgrade|failed-upgrade|abort-upgrade)
+ ;;
+
+ *)
+ echo "postrm called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e2e0b99
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+#MAKE_OPTIONS = VDRDIR=../../.. LIBDIR=. LOCALEDIR=locale
+MAKE_OPTIONS = VDRDIR=/usr/include/vdr LIBDIR=. LOCALEDIR=locale
+
+.PHONY: override_dh_strip override_dh_auto_install
+
+override_dh_strip:
+ dh_strip --dbg-package=vdr-plugin-smarttvweb
+
+override_dh_auto_install:
+ LIBDIR=. dh_auto_install --destdir=debian/vdr-plugin-smarttvweb
+
+override_dh_auto_build:
+ dh_auto_build -- all $(MAKE_OPTIONS)
+
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)