summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobin KAY <komadori@users.sourceforge.net>2004-08-30 00:55:18 +0000
committerRobin KAY <komadori@users.sourceforge.net>2004-08-30 00:55:18 +0000
commita5171860bcd55e56bacec9894c31c89d6b683494 (patch)
tree6f94208cb9079acfeee961a2948cec88d1fc58d8 /configure.ac
parent07be95eb3dc9d3a504df8d78a80c9136fbe2e866 (diff)
downloadxine-lib-a5171860bcd55e56bacec9894c31c89d6b683494.tar.gz
xine-lib-a5171860bcd55e56bacec9894c31c89d6b683494.tar.bz2
Fix the way the library path is supplied when testing for libdga. Disable compilation of win32/contrib/setenv.c on non-Win32 platforms (I don't see why it's necessary at all as we have xine_setenv). Front-ends use symbols in src/xine-utils but these aren't being exported in libxine.so because they come from an internal archive library. Compile xmlparser.c in src/xine-engine/Makefile.am for now (is there a better solution?).
CVS patchset: 6917 CVS date: 2004/08/30 00:55:18
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1cd9acc52..cdec66471 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,6 +644,8 @@ dnl ---------------------------------------------
dnl Check for Sun DGA
dnl ---------------------------------------------
+saved_LDFLAGS="$LDFLAGS"
+LDFLAGS="$LDFLAGS -L/usr/openwin/lib"
saved_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS -I/usr/openwin/include"
AC_CHECK_LIB(dga, XDgaGrabDrawable, [
@@ -651,8 +653,9 @@ AC_CHECK_LIB(dga, XDgaGrabDrawable, [
SUNDGA_CFLAGS="-I/usr/openwin/include"
SUNDGA_LIBS="-L/usr/openwin/lib -R/usr/openwin/lib -ldga"
ac_have_sundga=yes
- ], )
-], , "-L/usr/openwin/lib")
+ ])
+])
+LDFLAGS="$saved_LDFLAGS"
CPPFLAGS="$saved_CPPFLAGS"
AM_CONDITIONAL(HAVE_SUNDGA, [test x"$ac_have_sundga" = "xyes"])
AC_SUBST(SUNDGA_CFLAGS)