summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Caujolle-Bert <f1rmb@users.sourceforge.net>2002-03-28 12:44:37 +0000
committerDaniel Caujolle-Bert <f1rmb@users.sourceforge.net>2002-03-28 12:44:37 +0000
commit12ee56f278ece1d6e2e5a00ccb48ba94abb6addb (patch)
tree0afa8544764be5529fb821e7028d932897e73e32 /configure.in
parent4f0b8ee4cbf756e650af38472cd0f45b50978d2b (diff)
downloadxine-lib-12ee56f278ece1d6e2e5a00ccb48ba94abb6addb.tar.gz
xine-lib-12ee56f278ece1d6e2e5a00ccb48ba94abb6addb.tar.bz2
Ability to change logo at run-time. Fix endianness in xine-logoconv, build
and install it by default. CVS patchset: 1642 CVS date: 2002/03/28 12:44:37
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 26 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 1761411bd..669dd24be 100644
--- a/configure.in
+++ b/configure.in
@@ -246,6 +246,32 @@ AM_CONDITIONAL(HAVE_X11, [test x"$no_x" != "xyes"])
dnl
+dnl zlib
+dnl
+dnl Test for libz
+AC_CHECK_LIB(z, gzsetparams,
+ [ AC_CHECK_HEADER(zlib.h,
+ have_zlib=yes
+ ZLIB_LIBS="-lz",)])
+
+AM_CONDITIONAL(HAVE_ZLIB, [test x"$have_zlib" = "xyes"])
+AC_SUBST(ZLIB_LIBS)
+
+
+dnl
+dnl Imlib (for xine-logoconv)
+dnl
+AC_PATH_PROG(IMLIB_CONFIG, imlib-config, no)
+if test "$IMLIB_CONFIG" != "no" ; then
+ IMLIB_CFLAGS=`$IMLIB_CONFIG --cflags`
+ IMLIB_LIBS=`$IMLIB_CONFIG --libs`
+fi
+AM_CONDITIONAL(HAVE_IMLIB, [test x"$IMLIB_CONFIG" != x"no"])
+AC_SUBST(IMLIB_CFLAGS)
+AC_SUBST(IMLIB_LIBS)
+
+
+dnl
dnl Checks for Xv extension
dnl
dnl static linking with libXv is preferred!
@@ -510,13 +536,6 @@ AM_CONDITIONAL(HAVE_LIBFAME, test x"$have_libfame" = "xyes")
AM_CONDITIONAL(HAVE_LIBRTE, test x"$have_librte" = "xyes")
AM_CONDITIONAL(HAVE_ENCODER, test x"$have_encoder" = "xyes")
-dnl
-dnl zlib
-dnl
-dnl Test for libz
-AC_CHECK_LIB(z, gzsetparams, [AC_CHECK_HEADER(zlib.h,have_zlib=yes,)])
-AM_CONDITIONAL(HAVE_ZLIB, [test x"$have_zlib" = "xyes"])
-
dnl
dnl ASF build can be optional