summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 7 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 551238f94..235ef5987 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,11 +2,11 @@
## Process this file with automake to produce Makefile.in
##
-AUTOMAKE_OPTIONS = 1.8 no-dist-gzip dist-bzip2
+AUTOMAKE_OPTIONS = 1.9 no-dist-gzip dist-bzip2
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc m4 po misc include lib src win32
+SUBDIRS = doc m4 po misc include lib src win32 contrib
DEBFILES = debian/README.Debian debian/changelog debian/control \
debian/copyright debian/rules debian/compat \
@@ -21,8 +21,7 @@ EXTRA_DIST = config.rpath autogen.sh \
libtool \
ltmain.sh \
missing \
- depcomp \
- @DEPCOMP@
+ depcomp
CONFIG_CLEAN_FILES = libtool
@@ -41,22 +40,8 @@ pass2:
@$(MAKE) MULTIPASS_CFLAGS='$(PASS2_CFLAGS)'
-debug:
- @list='$(SUBDIRS)'; for subdir in $$list; do \
- (cd $$subdir && $(MAKE) $@) || exit;\
- done;
-
-debug-install: install-debug
-
-install-debug: debug
- @list='$(SUBDIRS)'; for subdir in $$list; do \
- (cd $$subdir && $(MAKE) $@) || exit; \
- done;
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
-
prune-cache:
- -rm -f config.cache
+ -rm -rf config.cache autom4te.cache
release-check:
@@ -92,6 +77,9 @@ install-data-hook:
$(top_srcdir)/post-install.sh ; \
fi
+dist-hook:
+ cp -p $(srcdir)/version.sh $(distdir)
+
mostlyclean-generic:
-rm -f *~ \#* .*~ .\#*