summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5780191b0..e7392cd42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -560,6 +560,13 @@ AM_PATH_OGG(
AC_MSG_RESULT([*** All of OGG/VORBIS dependent parts will be disabled ***]))
AM_CONDITIONAL(HAVE_VORBIS, [test x"$no_ogg" != "xyes" -a x"$no_vorbis" != "xyes"])
+dnl ---------------------------------------------
+dnl check for libFLAC
+dnl ---------------------------------------------
+AM_PATH_LIBFLAC(,
+ AC_DEFINE(HAVE_FLAC,1,[Define this if you have FLAC library installed]),
+ [])
+AM_CONDITIONAL(HAVE_FLAC, [test x"$no_flac" != x"yes"])
dnl ---------------------------------------------
dnl XviD libs.