summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 52d4c8502..66c580bdb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2139,8 +2139,10 @@ dnl Newest automake workaround
dnl ---------------------------------------------
AC_SUBST(mkdir_p)
-if test x"$mkdir_p" = "x"; then
- MKINSTALLDIRS="mkinstalldirs"
+if test -n "$ac_aux_dir"; then
+ MKINSTALLDIRS="$ac_aux_dir/install-sh -d"
+else
+ MKINSTALLDIRS="\$(top_srcdir)/install-sh -d"
fi
AC_SUBST(MKINSTALLDIRS)