summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 6606d2d81..e4b7518f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1503,12 +1503,18 @@ case "$host_or_hostalias" in
if test "$GCC" = yes ; then
dnl Check for gcc cpu optimization support
- AC_TRY_CFLAGS("-mcpu=i386",
- sarchopt="-mcpu",
- AC_TRY_CFLAGS("-march=i386",
- sarchopt="-march",
- [ AC_MSG_RESULT(** no cpu optimization supports **)
- sarchopt=no ]))
+ AC_TRY_CFLAGS("-mtune=i386",
+ sarchopt="-mtune",
+ AC_TRY_CFLAGS("-mcpu=i386",
+ sarchopt="-mcpu",
+ AC_TRY_CFLAGS("-march=i386",
+ sarchopt="-march",
+ [ AC_MSG_RESULT(** no cpu optimization supports **)
+ sarchopt=no
+ ]
+ )
+ )
+ )
dnl special check for k7 cpu CC support
AC_TRY_CFLAGS("$sarchopt=athlon", k7cpu="athlon", k7cpu="i686")