summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eccda25cc..30c0fb38c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,6 +326,13 @@ AC_SUBST(GLU_LIBS)
AM_CONDITIONAL(HAVE_OPENGL, [ test x$ac_have_opengl = "xyes" -a x$ac_have_glut="xyes" -o x$ac_have_opengl = "xyes" -a x$ac_have_glu="xyes" ] )
+dnl ----------------------------------------------
+dnl Check for usable video-for-linux (v4l) support
+dnl ----------------------------------------------
+AC_CHECK_HEADER(linux/videodev.h, have_v4l=yes,)
+AM_CONDITIONAL(HAVE_V4L, [test x"$have_v4l" = "xyes"])
+
+
host_or_hostalias="$host"
if test "$host_or_hostalias" = ""; then