summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d334f93c1..5c876eae8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -864,6 +864,20 @@ AC_SUBST(XVMC_LIBS)
dnl ---------------------------------------------
+dnl Check for VDPAU
+dnl ---------------------------------------------
+AC_ARG_WITH([vdpau], AS_HELP_STRING([--without-vdpau], [Doesn't build VDPAU plugins]))
+if test "x$with_vdpau" != "xno"; then
+ AC_CHECK_HEADERS([vdpau/vdpau_x11.h], [have_vdpau=yes], [have_vdpau=no])
+ if test "x$have_vdpau" = "xyes"; then
+ AC_CHECK_LIB(vdpau, vdp_device_create_x11, have_vdpau="yes", [have_vdpau="no"], [$X_LIBS $X_PRE_LIBS -lXext $X_EXTRA_LIBS])
+ fi
+fi
+
+AM_CONDITIONAL(HAVE_VDPAU, test "x$have_vdpau" = "xyes" )
+
+
+dnl ---------------------------------------------
dnl Check for xcb
dnl ---------------------------------------------
AC_ARG_WITH([xcb], AS_HELP_STRING([--without-xcb], [Doesn't build XCB video out plugins]))
@@ -3066,6 +3080,9 @@ if test "x$have_xcb" = "xyes"; then
echo " - xcb-xv (XVideo using XCB)"
fi
fi
+if test "x$have_vdpau" = "xyes"; then
+ echo " - vdpau (X11 VDPAU)"
+fi
if test "x$no_aalib" != "xyes"; then
echo " - aa (Ascii ART)"
fi