summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b175301be..f4f9b6563 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,9 +17,9 @@ dnl XINE_SUB += 1; XINE_PATCH = ''; continue with XINE_LT_* values below
dnl
XINE_MAJOR=1
XINE_MINOR=1
-XINE_SUB=20
+XINE_SUB=21
dnl XINE_PATCH should be left empty or set to ".1" or ".2" or something similar
-XINE_PATCH=.1
+XINE_PATCH=
dnl Release series number (usually $XINE_MAJOR.$XINE_MINOR)
XINE_SERIES=1.1
@@ -1674,6 +1674,22 @@ fi
AM_CONDITIONAL(HAVE_GDK_PIXBUF, test "x$no_gdkpixbuf" != "xyes")
dnl ---------------------------------------------
+dnl libbluray support
+dnl ---------------------------------------------
+AC_ARG_ENABLE([bluray],
+ AS_HELP_STRING([--disable-bluray], [Do not build BluRay support]),
+ [with_bluray=$enableval], [with_bluray=yes])
+
+if test "x$with_bluray" != "xno"; then
+ PKG_CHECK_MODULES([LIBBLURAY], [libbluray >= 0.2.1],
+ [have_libbluray=yes],
+ AC_MSG_RESULT(*** All of the libbluray dependent parts will be disabled ***))
+ AC_SUBST(LIBBLURAY_CFLAGS)
+ AC_SUBST(LIBBLURAY_LIBS)
+fi
+AM_CONDITIONAL(HAVE_LIBBLURAY, test "x$have_libbluray" = "xyes")
+
+dnl ---------------------------------------------
dnl libsmbclient support
dnl ---------------------------------------------
@@ -2954,6 +2970,9 @@ fi
if test "x$have_libsmbclient" = "xyes"; then
echo " - smbclient"
fi
+if test "x$have_libbluray" = x"yes"; then
+ echo " - bluray"
+fi
echo ""
dnl Demuxers