summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b175301be..5501ef72a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1674,6 +1674,22 @@ fi
AM_CONDITIONAL(HAVE_GDK_PIXBUF, test "x$no_gdkpixbuf" != "xyes")
dnl ---------------------------------------------
+dnl libbluray support
+dnl ---------------------------------------------
+AC_ARG_ENABLE([bluray],
+ AS_HELP_STRING([--disable-bluray], [Do not build BluRay support]),
+ [with_bluray=$enableval], [with_bluray=yes])
+
+if test "x$with_bluray" != "xno"; then
+ PKG_CHECK_MODULES([LIBBLURAY], [libbluray >= 0.2.1],
+ [have_libbluray=yes],
+ AC_MSG_RESULT(*** All of the libbluray dependent parts will be disabled ***))
+ AC_SUBST(LIBBLURAY_CFLAGS)
+ AC_SUBST(LIBBLURAY_LIBS)
+fi
+AM_CONDITIONAL(HAVE_LIBBLURAY, test "x$have_libbluray" = "xyes")
+
+dnl ---------------------------------------------
dnl libsmbclient support
dnl ---------------------------------------------
@@ -2954,6 +2970,9 @@ fi
if test "x$have_libsmbclient" = "xyes"; then
echo " - smbclient"
fi
+if test "x$have_libbluray" = x"yes"; then
+ echo " - bluray"
+fi
echo ""
dnl Demuxers