summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in56
1 files changed, 55 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fcc58e22d..a897a82bc 100644
--- a/configure.in
+++ b/configure.in
@@ -140,6 +140,58 @@ fi
dnl
+dnl Checks for X11
+dnl
+AC_PATH_XTRA
+if test x"$no_x" != "xyes"; then
+ AC_DEFINE(HAVE_X11)
+fi
+AM_CONDITIONAL(HAVE_X11, test x"$no_x" != "xyes")
+
+
+dnl
+dnl Checks for Xv extension
+dnl
+
+AC_CHECK_LIB(Xv, XvShmCreateImage,
+ X_LIBS="$X_LIBS -lXv"
+ AC_DEFINE(HAVE_XV)
+ ac_have_xv="yes",,
+ $X_LIBS $X_PRE_LIBS -lXext $X_EXTRA_LIBS)
+AM_CONDITIONAL(HAVE_XV, test x$ac_have_xv = "xyes")
+
+
+dnl
+dnl Checks for Xinerama extension
+dnl
+
+AC_CHECK_LIB(Xinerama, XineramaQueryExtension,
+ X_LIBS="$X_LIBS -lXinerama"
+ AC_DEFINE(HAVE_XINERAMA)
+ ac_have_xinerama="yes",,
+ $X_LIBS $X_PRE_LIBS -lXext $X_EXTRA_LIBS)
+AM_CONDITIONAL(HAVE_XINERAMA, test x$ac_have_xinerama = "xyes")
+
+
+dnl
+dnl Alsa support
+dnl
+AM_PATH_ALSA(0.5.5,
+ AC_DEFINE(HAVE_ALSA),
+ AC_MSG_RESULT(*** All of ALSA dependent parts will be disabled ***))
+AM_CONDITIONAL(HAVE_ALSA, test x"$no_alsa" != "xyes")
+
+
+dnl
+dnl ESD support
+dnl
+AM_PATH_ESD(0.2.8,
+ AC_DEFINE(HAVE_ESD),
+ AC_MSG_RESULT(*** All of ESD dependent parts will be disabled ***))
+AM_CONDITIONAL(HAVE_ESD, test x"$no_esd" != "xyes")
+
+
+dnl
dnl
dnl
AC_CHECK_FUNC(getpwuid_r,AC_DEFINE(HAVE_GETPWUID_R))
@@ -314,7 +366,7 @@ AC_SUBST(w32_path)
dnl
dnl Some include paths ( !!! DO NOT REMOVE !!! )
dnl
-INCLUDES='-I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine -I$(top_srcdir)/include -I$(top_builddir/)/include'
+INCLUDES='-I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine'
AC_SUBST(INCLUDES)
@@ -341,6 +393,8 @@ Makefile
include/Makefile
include/xine.h.tmpl
src/Makefile
+src/audio_out/Makefile
+src/video_out/Makefile
src/demuxers/Makefile
src/libmpeg2/Makefile
src/libac3/Makefile