summaryrefslogtreecommitdiff
path: root/contrib/gsm610/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gsm610/Makefile.am')
-rw-r--r--contrib/gsm610/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/contrib/gsm610/Makefile.am b/contrib/gsm610/Makefile.am
new file mode 100644
index 000000000..f2011dfd4
--- /dev/null
+++ b/contrib/gsm610/Makefile.am
@@ -0,0 +1,26 @@
+include $(top_srcdir)/misc/Makefile.common
+
+AM_CFLAGS = $(DEFAULT_OCFLAGS) $(VISIBILITY_FLAG)
+AM_LDFLAGS = $(xineplug_ldflags)
+
+noinst_LTLIBRARIES = libgsm610.la
+
+libgsm610_la_SOURCES = \
+ add.c \
+ decode.c \
+ gsm_create.c \
+ gsm_decode.c \
+ gsm_destroy.c \
+ long_term.c \
+ lpc.c \
+ rpe.c \
+ short_term.c \
+ table.c
+
+
+noinst_HEADERS = \
+ gsm_config.h \
+ gsm.h \
+ private.h \
+ proto.h \
+ unproto.h