summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 7fae3ae20..605497d8d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,7 +28,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
BUILD_TARGET := debug
endif
-DEB_HOST_GNU_OPTION :=
+DEB_BUILD_GNU_OPTION :=
# the "optimize" flag disables compatibility hacks
ifeq (,$(findstring optimize,$(DEB_BUILD_OPTIONS)))
$(warning trying to disable machine-specific optimizations)
@@ -42,20 +42,20 @@ ifeq (,$(findstring optimize,$(DEB_BUILD_OPTIONS)))
$(shell echo $(DEB_HOST_GNU_TYPE)|sed -e 's/^i.86/i686/')
DEB_BUILD_GNU_TYPE := \
$(shell echo $(DEB_BUILD_GNU_TYPE)|sed -e 's/^i.86/i686/')
- ifneq ($DEB_HOST_GNU_TYPE,$DEB_BUILD_GNU_TYPE)
+ ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
$(warning WARNING: cross compiling is not supported by xine)
$(warning using DEB_BUILD_GNU_TYPE = $(DEB_BUILD_GNU_TYPE))
$(warning ignoring DEB_HOST_GNU_TYPE = $(DEB_HOST_GNU_TYPE))
DEB_HOST_GNU_TYPE := $(DEB_BUILD_GNU_TYPE)
endif
- DEB_HOST_GNU_OPTION := --host=$(DEB_HOST_GNU_TYPE)
+ DEB_BUILD_GNU_OPTION := --build=$(DEB_BUILD_GNU_TYPE)
endif
configure: configure-stamp
configure-stamp:
dh_testdir
./configure --prefix=/usr --mandir=\$${prefix}/share/man \
- $(DEB_HOST_GNU_OPTION)
+ $(DEB_BUILD_GNU_OPTION) CFLAGS="$(CFLAGS)"
touch configure-stamp
build: configure-stamp build-stamp