summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 5 insertions, 20 deletions
diff --git a/debian/rules b/debian/rules
index 446f6e9cb..a09eb29b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,16 +22,8 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_BUILD_CONFIG_OPTIONS :=
-CFLAGS += -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- DEB_BUILD_CONFIG_OPTIONS += --disable-optimizations
-endif
-INSTALL_TARGET := install
-BUILD_TARGET := all
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_TARGET := install-debug
- BUILD_TARGET := debug
+ DEB_BUILD_CONFIG_OPTIONS += --disable-optimizations --enable-debug
endif
ifneq (,$(findstring mips,$(DEB_HOST_GNU_TYPE)))
@@ -75,18 +67,11 @@ CONFIGURE_FLAGS := \
--build $(DEB_BUILD_GNU_TYPE) \
--host $(DEB_HOST_GNU_TYPE) \
--prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --with-external-libmad \
- --with-external-a52dec \
- --with-external-libdts \
- --with-external-ffmpeg \
- --with-external-libmpcdec \
- --with-external-dvdnav \
--with-freetype \
--with-wavpack \
--enable-ipv6 \
- $(DEB_BUILD_CONFIG_OPTIONS) \
- CFLAGS="$(CFLAGS)"
+ --with-external-dvdnav \
+ $(DEB_BUILD_CONFIG_OPTIONS)
configure: configure-stamp
configure-stamp:
@@ -154,10 +139,10 @@ binary-arch: build install
dh_installdocs
dh_installchangelogs -k ChangeLog
dh_link
- dh_strip --dbg-package=libxine1
+ dh_strip --dbg-package=libxine2
dh_compress
dh_fixperms
- dh_makeshlibs -V 'libxine1 (>= 1.1.2-5)'
+ dh_makeshlibs -V 'libxine2 (>= 1.1.90)'
dh_installdeb
chmod +x debian/shlibdeps.sh
debian/shlibdeps.sh libxine${major}