summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 8 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 8e4ca67fe..76b0a6c63 100755
--- a/debian/rules
+++ b/debian/rules
@@ -60,11 +60,13 @@ endif
# --mandir - remove after etch released (autoconf >= 2.59c gets it right)
CONFIGURE_FLAGS := --prefix=/usr \
- --mandir=\$${prefix}/share/man \
--with-external-libmad \
--with-external-a52dec \
--with-external-libdts \
- --disable-cacatest \
+ --with-external-faad \
+ --with-external-ffmpeg=soft \
+ --with-freetype \
+ --with-wavpack \
$(DEB_BUILD_CONFIG_OPTIONS) \
CFLAGS="$(CFLAGS)"
@@ -101,8 +103,8 @@ clean:
-$(MAKE) distclean
# remove more cruft leftover by autohell
rm -f doc/faq/faq.html doc/faq/faq.txt doc/hackersguide/hackersguide.html m4/caca.m4
- -test -f .noauto || find . -name Makefile.in -print | xargs rm
- test -f .noauto || rm -rf compile config.guess configure depcomp install-sh ltmain.sh missing aclocal.m4 config.h.in
+ -test -f .noauto || find . -name Makefile.in -print | xargs -r rm
+ test -f .noauto || rm -rf compile config.guess configure depcomp install-sh ltmain.sh missing aclocal.m4 include/configure.h.in
dh_clean
install: build
@@ -129,10 +131,10 @@ binary-arch: build install
dh_installdocs
dh_installchangelogs -k ChangeLog
dh_link
- dh_strip --dbg-package=libxine1
+ dh_strip --dbg-package=libxine2
dh_compress
dh_fixperms
- dh_makeshlibs -V 'libxine1 (>= 1.1.2-5)'
+ dh_makeshlibs -V 'libxine2 (>= 1.2.0~)'
dh_installdeb
chmod +x debian/shlibdeps.sh
debian/shlibdeps.sh libxine${major}