summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/dh_xine38
-rw-r--r--debian/dh_xine.116
-rw-r--r--debian/libxine-dev.install2
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/xine.pm9
5 files changed, 58 insertions, 10 deletions
diff --git a/debian/dh_xine b/debian/dh_xine
index 93657a86c..1ae22bd9b 100644
--- a/debian/dh_xine
+++ b/debian/dh_xine
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_xine> [S<I<debhelper options>>]
+B<dh_xine> [S<I<debhelper options>>] [S<I<package name suffixes>>]
=head1 DESCRIPTION
@@ -23,6 +23,19 @@ Each xine-lib front end is required to have one of these two substvars
listed in its Depends line in debian/control. Using package names directly
will, sooner or later, break.
+By listing package name suffixes, you can generate dependencies and
+recommendations (almost) at will. If you don't specify any, then 'x' and
+'console' are used, generating xine-x:Depends and xine-console:Depends.
+
+=head1 EXAMPLES
+
+dh_xine is usually called indirectly in a rules file via the dh command.
+
+ %:
+ dh --with xine $@
+
+It can also be called directly, prior to calling dh_gencontrol.
+
=head1 CONFORMS TO
Debian policy, version 3.8.1
@@ -31,16 +44,27 @@ Debian policy, version 3.8.1
init ();
-my $version;
+no locale;
+
+my @suffix;
+
+foreach my $suffix (@ARGV) {
+ if ($suffix =~ /^[-[:lower:]]*$/) {
+ push @suffix, $suffix;
+ } else {
+ warn "bad package name suffix: $suffix";
+ }
+}
+
+@suffix = ('x', 'console') if $#suffix < 0;
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp = tmpdir ($package);
- delsubstvar($package, 'xine-x:Depends');
- addsubstvar ($package, 'xine-x:Depends', 'libxine2-x');
-
- delsubstvar($package, 'xine-console:Depends');
- addsubstvar ($package, 'xine-console:Depends', 'libxine2-console');
+ foreach my $suffix (@suffix) {
+ delsubstvar($package, "xine-$suffix:Depends");
+ addsubstvar ($package, "xine-$suffix:Depends", "libxine1-$suffix");
+ }
}
=head1 SEE ALSO
diff --git a/debian/dh_xine.1 b/debian/dh_xine.1
index 5116d750a..e420abd7e 100644
--- a/debian/dh_xine.1
+++ b/debian/dh_xine.1
@@ -2,7 +2,7 @@
.SH "NAME"
dh_xine - calculates xine\-lib dependencies
.SH "SYNOPSIS"
-\fBdh_xine\fR [\fIdebhelper\ options\fR]
+\fBdh_xine\fR [\fIdebhelper\ options\fR] [\fIpackage\ name\ suffixes\fR]
.SH "DESCRIPTION"
dh_xine is a debhelper program that is responsible for generating the
${xine\-x:Depends} and ${xine\-console:Depends} substitutions and adding them
@@ -11,6 +11,20 @@ to substvars files.
Each xine-lib front end is required to have one of these two substvars
listed in its Depends line in debian/control. Using package names directly
will, sooner or later, break.
+.PP
+By listing package name suffixes, you can generate dependencies and
+recommendations (almost) at will. If you don't specify any, then 'x' and
+\&'console' are used, generating xine\-x:Depends and xine\-console:Depends.
+.SH "EXAMPLES"
+dh_xine is usually called indirectly in a rules file via the dh command.
+.PP
+.ft CW
+.nf
+\& %:
+\& dh \-\-with xine $@
+.ft R
+.PP
+It can also be called directly, prior to calling dh_gencontrol.
.SH "CONFORMS TO"
Debian policy, version 3.8.1
.SH "SEE ALSO"
diff --git a/debian/libxine-dev.install b/debian/libxine-dev.install
index 6fadf7dc5..10a9d7983 100644
--- a/debian/libxine-dev.install
+++ b/debian/libxine-dev.install
@@ -8,3 +8,5 @@ usr/lib/xine/plugins/*/post/*.la
usr/lib/xine/plugins/*/vidix/*.la
usr/share/aclocal/xine.m4
usr/share/man/man1/xine-config.1
+../dh_xine usr/bin
+../xine.pm usr/share/perl5/Debian/Debhelper/Sequence/xine.pm
diff --git a/debian/rules b/debian/rules
index 0e03b0edd..a604bb1df 100755
--- a/debian/rules
+++ b/debian/rules
@@ -130,8 +130,7 @@ binary-arch: build install
# ugly hack, documentation should never have been in /u/s/d/xine/...
mv debian/tmp/usr/share/doc/xine-lib debian/tmp/usr/share/doc/libxine${major}
# build libxine${major} package by moving files from libxine-dev
- dh_install --autodest --sourcedir=debian/tmp --list-missing
- install -m755 debian/dh_xine debian/libxine-dev/usr/bin
+ dh_install --sourcedir=debian/tmp --list-missing
dh_installman -plibxine-dev debian/dh_xine.1
dh_installdocs
dh_installchangelogs -k ChangeLog
diff --git a/debian/xine.pm b/debian/xine.pm
new file mode 100644
index 000000000..81abf05a6
--- /dev/null
+++ b/debian/xine.pm
@@ -0,0 +1,9 @@
+#!/usr/bin/perl
+
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+insert_after("dh_shlibdeps", "dh_xine");
+
+1;