summaryrefslogtreecommitdiff
path: root/doc/faq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/faq/Makefile.am')
-rw-r--r--doc/faq/Makefile.am30
1 files changed, 22 insertions, 8 deletions
diff --git a/doc/faq/Makefile.am b/doc/faq/Makefile.am
index 21d2851e0..3370a4c5f 100644
--- a/doc/faq/Makefile.am
+++ b/doc/faq/Makefile.am
@@ -1,36 +1,50 @@
include $(top_srcdir)/misc/Makefile.common
EXTRA_DIST = README faq.sgml
+
docs_DATA = faq.html faq.txt
docsdir = $(prefix)/share/doc/xine/faq
-docs: docs-prepare $(docs_DATA)
+docs: $(docs_DATA)
+
+distclean-generic: clean-docs
-docs-prepare: $(srcdir)/faq.sgml
- test -f faq.sgml || cp $^ .
+clean-docs:
+ rm -f $(docs_DATA)
+ test "x$(srcdir)" = x. || rm -f faq.sgml
dist-hook:
- @touch $(addprefix $(srcdir)/, $(EXTRA_DIST))
@make fail_if_missing=yes docs
cp $(docs_DATA) $(distdir)
+faq.sgml: $(srcdir)/faq.sgml
+ cp $^ .
+
faq.html: faq.sgml
@if test "$(SGMLTOOLS)" != "no"; then \
$(SGMLTOOLS) -b onehtml faq.sgml; \
- else if test "$(fail_if_missing)" = "yes"; then \
+ else \
+ if test "$(fail_if_missing)" = "yes"; then \
echo "Please install sgmltools-lite."; \
exit 1; \
- else touch $@; \
+ else \
+ touch $@; \
+ sleep 1; \
+ touch $^; \
fi; \
fi
faq.txt: faq.sgml
@if test "$(SGMLTOOLS)" != "no"; then \
$(SGMLTOOLS) -b txt faq.sgml; \
- else if test "$(fail_if_missing)" = "yes"; then \
+ else \
+ if test "$(fail_if_missing)" = "yes"; then \
echo "Please install sgmltools-lite."; \
exit 1; \
- else touch $@; \
+ else \
+ touch $@; \
+ sleep 1; \
+ touch $^; \
fi; \
fi