summaryrefslogtreecommitdiff
path: root/doc/faq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/faq/Makefile.am')
-rw-r--r--doc/faq/Makefile.am29
1 files changed, 4 insertions, 25 deletions
diff --git a/doc/faq/Makefile.am b/doc/faq/Makefile.am
index 1e6fe0142..dadf02021 100644
--- a/doc/faq/Makefile.am
+++ b/doc/faq/Makefile.am
@@ -1,36 +1,15 @@
include $(top_srcdir)/misc/Makefile.common
EXTRA_DIST = README faq.sgml
-docs_DOCS = faq.html faq.txt
+docs_DATA = faq.html faq.txt
-docdir = $(prefix)/share/doc/xine/faq
+docsdir = $(prefix)/share/doc/xine/faq
-install-data-local:
- @documentations='$(docs_DOCS)'; \
- for doc in $$documentations; do \
- destdir=$(DESTDIR)$(docdir); \
- name=`echo $$doc` \
- dir=$$destdir; \
- $(mkinstalldirs) $$dir; \
- $(INSTALL_DATA) $$doc $$dir/$$name; \
- echo "installing $$doc as $$dir/$$name"; \
- done
-
-uninstall-local:
- @documentations='$(docs_DOCS)'; \
- for doc in $$documentations; do \
- destdir=$(DESTDIR)$(docdir); \
- name=`echo $$doc` \
- dir=$$destdir; \
- rm -f $$dir/$$name; \
- echo "removing $$dir/$$name" ; \
- done
-
-docs: $(docs_DOCS)
+docs: $(docs_DATA)
dist-hook:
@make fail_if_missing=yes docs
- cp $(docs_DOCS) $(distdir)
+ cp $(docs_DATA) $(distdir)
faq.html: faq.sgml
@if test "$(SGMLTOOLS)" != "no"; then \