summaryrefslogtreecommitdiff
path: root/doc/faq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/faq/Makefile.am')
-rw-r--r--doc/faq/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/doc/faq/Makefile.am b/doc/faq/Makefile.am
index 291e4718b..9a3d5079a 100644
--- a/doc/faq/Makefile.am
+++ b/doc/faq/Makefile.am
@@ -1,7 +1,32 @@
-EXTRA_DIST = README faq.sgml
-
+EXTRA_DIST = $(docs_DOCS) README faq.sgml
docdir = $(prefix)/share/doc/xine/faq
+docs_DOCS = faq.html faq.txt
+
+
+install-data-local:
+ @documentations='$(docs_DOCS)'; \
+ for doc in $$documentations; do \
+ destdir=$(DESTDIR)$(docdir); \
+ name=`echo $$doc` \
+ dir=$$destdir; \
+ $(mkinstalldirs) $$dir; \
+ $(INSTALL_DATA) $$doc $$dir/$$name; \
+ echo "installing $$doc as $$dir/$$name"; \
+ done
+
+uninstall-local:
+ @documentations='$(docs_DOCS)'; \
+ for doc in $$documentations; do \
+ destdir=$(DESTDIR)$(docdir); \
+ name=`echo $$doc` \
+ dir=$$destdir; \
+ rm -f $$dir/$$name; \
+ echo "removing $$dir/$$name" ; \
+ done
+
+debug:
+install-debug: install
mostlyclean-generic:
-rm -f *~ \#* .*~ .\#*