summaryrefslogtreecommitdiff
path: root/doc/faq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/faq/Makefile.am')
-rw-r--r--doc/faq/Makefile.am55
1 files changed, 19 insertions, 36 deletions
diff --git a/doc/faq/Makefile.am b/doc/faq/Makefile.am
index 6090fd272..4a5c2f6f9 100644
--- a/doc/faq/Makefile.am
+++ b/doc/faq/Makefile.am
@@ -1,22 +1,17 @@
+include $(top_srcdir)/misc/Makefile.quiet
include $(top_srcdir)/misc/Makefile.common
doc_DATA = faq.txt
html_DATA = faq.html
-EXTRA_DIST = README faq.sgml $(doc_DATA) $(html_DATA)
+EXTRA_DIST = README faq.docbook faq.xsl $(doc_DATA) $(html_DATA)
-docs: $(doc_DATA) $(html_DATA)
+DISTCLEANFILES = $(doc_DATA) $(html_DATA)
-distclean-local: clean-docs
-
-docs-prepare: $(srcdir)/faq.sgml
- if test "$(srcdir)" != "." -a "$(srcdir)" != "`pwd`"; then \
- test -f ./faq.sgml -a ./faq.sgml -nt $(srcdir)/faq.sgml || cp $^ . ; \
- fi
+docs: $(hackersguide_DATA)
clean-docs:
- rm -f $(doc_DATA) $(html_DATA)
- test "x$(srcdir)" = x. || rm -f faq.sgml
+ rm -f $(hackersguide_DATA)
dist-hook:
@if test x"$(distcheck_lax)" = x ; then \
@@ -25,38 +20,26 @@ dist-hook:
$(MAKE) docs ; \
fi
-if HAVE_SGMLTOOLS
-faq.html: faq.sgml
- @$(MAKE) docs-prepare
- $(SGMLTOOLS) -b onehtml faq.sgml;
-else
-faq.html: faq.sgml
- @$(MAKE) docs-prepare
- if test x"$(fail_if_missing)" = x"yes"; then \
- echo "Please install sgmltools-lite."; \
- exit 1; \
- fi
- if test x"$(fail_if_missing)" != x"yes"; then \
- touch $@; \
- sleep 1; \
- touch $(notdir $^); \
- fi
-endif
+distclean-local: clean-docs
+
+AM_V_FAKE = $(am__v_FAKE_$(V))
+am__v_FAKE_ = $(am__v_FAKE_$(AM_DEFAULT_VERBOSITY))
+am__v_FAKE_0 = @echo " FAKE " $@;
-if HAVE_SGMLTOOLS
-faq.txt: faq.sgml
- @$(MAKE) docs-prepare
- $(SGMLTOOLS) -b txt faq.sgml;
+if HAVE_XMLTO
+faq.html: faq.docbook faq.xsl
+ $(AM_V_GEN)xmlto -m faq.xsl xhtml-nochunks $<
+faq.txt: faq.docbook faq.xsl
+ $(AM_V_GEN)xmlto -m faq.xsl txt $<
else
-faq.txt: faq.sgml
- @$(MAKE) docs-prepare
- if test x"$(fail_if_missing)" = x"yes"; then \
- echo "Please install sgmltools-lite."; \
+faq.html faq.txt: faq.docbook
+ $(AM_V_FAKE)if test x"$(fail_if_missing)" = x"yes"; then \
+ echo "Please install xmlto."; \
exit 1; \
fi
if test x"$(fail_if_missing)" != x"yes"; then \
touch $@; \
sleep 1; \
- touch $(notdir $^); \
+ touch $^; \
fi
endif