summaryrefslogtreecommitdiff
path: root/doc/man/en/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/man/en/Makefile.am')
-rw-r--r--doc/man/en/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/doc/man/en/Makefile.am b/doc/man/en/Makefile.am
index ee0296033..9fe87cc11 100644
--- a/doc/man/en/Makefile.am
+++ b/doc/man/en/Makefile.am
@@ -1,5 +1,13 @@
include $(top_srcdir)/misc/Makefile.common
-man_MANS = xine-config.1 xine.5
+STATICMANS = xine-config.1 xine.5
+DYNAMICMANS = xine-list-@XINE_SERIES@.1
-EXTRA_DIST = $(man_MANS)
+man_MANS = $(STATICMANS) $(DYNAMICMANS)
+
+BUILT_SOURCES = $(DYNAMICMANS)
+DISTCLEANFILES = $(DYNAMICMANS)
+EXTRA_DIST = $(STATICMANS) xine-list.1.in
+
+xine-list-@XINE_SERIES@.1: xine-list.1.in
+ (echo '.ds xl xine\-list\-@XINE_SERIES@'; cat $<) >$@