summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5217afe55..37559c298 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,12 +1,15 @@
include $(top_srcdir)/misc/Makefile.common
+if GENERATED_INTTYPES_H
+inttypes_h = inttypes.h
+endif
+
EXTRA_DIST = Makefile.common
+CONFIG_CLEAN_FILES = $(inttypes_h)
noinst_LTLIBRARIES = libxineposix.la
-
noinst_HEADERS = os_internal.h
-
-include_HEADERS = os_types.h
+include_HEADERS = os_types.h $(inttypes_h)
libxineposix_la_SOURCES =
libxineposix_la_LIBADD = @LTLIBOBJS@