summaryrefslogtreecommitdiff
path: root/src/input/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/input/Makefile.am')
-rw-r--r--src/input/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/input/Makefile.am b/src/input/Makefile.am
index 10c4f15ec..9700f6f58 100644
--- a/src/input/Makefile.am
+++ b/src/input/Makefile.am
@@ -56,6 +56,10 @@ if DVB
in_dvb = xineplug_inp_dvb.la
endif
+if HAVE_LIBBLURAY
+in_bluray = xineplug_inp_bluray.la
+endif
+
AM_CFLAGS = -D_LARGEFILE64_SOURCE $(GNOME_VFS_CFLAGS) $(ALSA_CFLAGS) $(DVD_CFLAGS)
xineplug_LTLIBRARIES = \
@@ -75,6 +79,7 @@ xineplug_LTLIBRARIES = \
xineplug_inp_net.la \
$(in_pvr) \
$(in_dvb) \
+ $(in_bluray) \
xineplug_inp_cdda.la
@@ -163,6 +168,11 @@ xineplug_inp_pvr_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL)
xineplug_inp_pvr_la_CFLAGS = $(VISIBILITY_FLAG) $(AM_CFLAGS)
xineplug_inp_pvr_la_LDFLAGS = $(xineplug_ldflags)
+xineplug_inp_bluray_la_SOURCES = input_bluray.c media_helper.c
+xineplug_inp_bluray_la_LIBADD = $(XINE_LIB) $(LIBBLURAY_LIBS) $(PTHREAD_LIBS) $(LTLIBINTL)
+xineplug_inp_bluray_la_CFLAGS = $(VISIBILITY_FLAG) $(AM_CFLAGS) $(LIBBLURAY_CFLAGS)
+xineplug_inp_bluray_la_LDFLAGS = $(xineplug_ldflags)
+
xineinclude_HEADERS = input_plugin.h
noinst_HEADERS = net_buf_ctrl.h mms.h mmsh.h pnm.h media_helper.h http_helper.h