summaryrefslogtreecommitdiff
path: root/src/liba52/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/liba52/Makefile.am')
-rw-r--r--src/liba52/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/liba52/Makefile.am b/src/liba52/Makefile.am
index 6857bcea3..d786ab250 100644
--- a/src/liba52/Makefile.am
+++ b/src/liba52/Makefile.am
@@ -4,16 +4,28 @@ libdir = $(XINE_PLUGINDIR)
lib_LTLIBRARIES = xineplug_decode_a52.la
-xineplug_decode_a52_la_SOURCES = \
+if EXTERNAL_A52DEC
+internal_sources =
+else
+internal_sources = \
bitstream.c \
bit_allocate.c \
- crc.c \
downmix.c \
imdct.c \
- parse.c \
- xine_decoder.c
+ parse.c
+endif
+
+xineplug_decode_a52_la_SOURCES = \
+ crc.c \
+ xine_decoder.c \
+ $(internal_sources)
+if EXTERNAL_A52DEC
+xineplug_decode_a52_la_LIBADD = $(XINE_LIB) -la52 -lm
+else
xineplug_decode_a52_la_LIBADD = $(XINE_LIB)
+endif
+
xineplug_decode_a52_la_LDFLAGS = -avoid-version -module @XINE_PLUGIN_MIN_SYMS@
noinst_HEADERS = \