summaryrefslogtreecommitdiff
path: root/src/libdts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libdts/Makefile.am')
-rw-r--r--src/libdts/Makefile.am26
1 files changed, 7 insertions, 19 deletions
diff --git a/src/libdts/Makefile.am b/src/libdts/Makefile.am
index ea09aab2e..c142d3945 100644
--- a/src/libdts/Makefile.am
+++ b/src/libdts/Makefile.am
@@ -4,25 +4,13 @@ if DTS
dts_module = xineplug_decode_dts.la
endif
-xineplug_LTLIBRARIES = $(dts_module)
+$(top_builddir)/contrib/libdca/libdca.la:
+ $(MAKE) -C $(top_builddir)/contrib/libdca
-if EXTERNAL_LIBDTS
-fnsa =
-internal_sources =
-else
-fnsa = -fno-strict-aliasing
-internal_sources = bitstream.c downmix.c parse.c
-endif
+xineplug_LTLIBRARIES = $(dts_module)
-xineplug_decode_dts_la_SOURCES = xine_dts_decoder.c $(internal_sources)
-xineplug_decode_dts_la_CFLAGS = $(LIBDTS_CFLAGS) $(VISIBILITY_FLAG) $(fnsa)
+xineplug_decode_dts_la_SOURCES = xine_dts_decoder.c
+xineplug_decode_dts_la_CFLAGS = $(LIBDTS_CFLAGS) $(VISIBILITY_FLAG)
+xineplug_decode_dts_la_DEPENDENCIES = $(LIBDTS_DEPS)
+xineplug_decode_dts_la_LIBADD = $(XINE_LIB) $(LIBDTS_LIBS)
xineplug_decode_dts_la_LDFLAGS = $(xineplug_ldflags)
-
-if EXTERNAL_LIBDTS
-xineplug_decode_dts_la_LIBADD = $(XINE_LIB) $(LIBDTS_LIBS) -lm
-else
-xineplug_decode_dts_la_LIBADD = $(XINE_LIB) -lm
-endif
-
-noinst_HEADERS = bitstream.h internal-dts.h dts_internal.h tables.h tables_adpcm.h \
- tables_fir.h tables_huffman.h tables_quantization.h tables_vq.h