summaryrefslogtreecommitdiff
path: root/src/libmpeg2new/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libmpeg2new/Makefile.am')
-rw-r--r--src/libmpeg2new/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/libmpeg2new/Makefile.am b/src/libmpeg2new/Makefile.am
index 49959da86..8c248fdcb 100644
--- a/src/libmpeg2new/Makefile.am
+++ b/src/libmpeg2new/Makefile.am
@@ -1,13 +1,12 @@
include $(top_srcdir)/misc/Makefile.common
+AM_CFLAGS = $(DEFAULT_OCFLAGS) $(VISIBILITY_FLAG)
+AM_LDFLAGS = $(xineplug_ldflags)
+
SUBDIRS = libmpeg2
xineplug_LTLIBRARIES = xineplug_decode_mpeg2.la
-xineplug_decode_mpeg2_la_SOURCES = \
- xine_mpeg2_decoder.c
-
-xineplug_decode_mpeg2_la_CFLAGS = $(VISIBILITY_FLAG) $(LIBMPEG2_CFLAGS)
+xineplug_decode_mpeg2_la_SOURCES = xine_mpeg2_decoder.c
xineplug_decode_mpeg2_la_LIBADD = $(XINE_LIB) ./libmpeg2/libmpeg2.la
-xineplug_decode_mpeg2_la_LDFLAGS = $(xineplug_ldflags)
-
+xineplug_decode_mpeg2_la_CFLAGS = $(AM_CFLAGS) $(MLIB_CFLAGS)