summaryrefslogtreecommitdiff
path: root/src/libreal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libreal/Makefile.am')
-rw-r--r--src/libreal/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/libreal/Makefile.am b/src/libreal/Makefile.am
index 21c2e47ba..114a473a7 100644
--- a/src/libreal/Makefile.am
+++ b/src/libreal/Makefile.am
@@ -1,15 +1,12 @@
include $(top_srcdir)/misc/Makefile.common
if ENABLE_REAL
-xineplug_LTLIBRARIES = xineplug_decode_real.la xineplug_decode_real_audio.la
+xineplug_LTLIBRARIES = xineplug_decode_real.la
endif
-xineplug_decode_real_la_SOURCES = xine_decoder.c real_common.c
+xineplug_decode_real_la_SOURCES = xine_decoder.c real_common.c audio_decoder.c
xineplug_decode_real_la_LIBADD = $(XINE_LIB) $(DYNAMIC_LD_LIBS)
xineplug_decode_real_la_CFLAGS = $(VISIBILITY_FLAG)
xineplug_decode_real_la_LDFLAGS = $(xineplug_ldflags)
-xineplug_decode_real_audio_la_SOURCES = audio_decoder.c real_common.c
-xineplug_decode_real_audio_la_LIBADD = $(XINE_LIB) $(DYNAMIC_LD_LIBS)
-xineplug_decode_real_audio_la_CFLAGS = $(VISIBILITY_FLAG)
-xineplug_decode_real_audio_la_LDFLAGS = $(xineplug_ldflags)
+noinst_HEADERS = real_common.h