summaryrefslogtreecommitdiff
path: root/src/libreal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libreal/Makefile.am')
-rw-r--r--src/libreal/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/libreal/Makefile.am b/src/libreal/Makefile.am
index 90e47a63c..301ad9b23 100644
--- a/src/libreal/Makefile.am
+++ b/src/libreal/Makefile.am
@@ -1,13 +1,14 @@
include $(top_builddir)/misc/Makefile.plugins
include $(top_srcdir)/misc/Makefile.common
+AM_CFLAGS = $(DEFAULT_OCFLAGS) $(VISIBILITY_FLAG)
+AM_LDFLAGS = $(xineplug_ldflags)
+
+noinst_HEADERS = real_common.h
+
if ENABLE_REAL
xineplug_LTLIBRARIES = xineplug_decode_real.la
endif
xineplug_decode_real_la_SOURCES = xine_real_video_decoder.c real_common.c xine_real_audio_decoder.c
xineplug_decode_real_la_LIBADD = $(XINE_LIB) $(DYNAMIC_LD_LIBS) $(LTLIBINTL)
-xineplug_decode_real_la_CFLAGS = $(VISIBILITY_FLAG)
-xineplug_decode_real_la_LDFLAGS = $(xineplug_ldflags)
-
-noinst_HEADERS = real_common.h