summaryrefslogtreecommitdiff
path: root/src/libxinevdec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libxinevdec/Makefile.am')
-rw-r--r--src/libxinevdec/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/libxinevdec/Makefile.am b/src/libxinevdec/Makefile.am
index 903399cbb..87ee050e6 100644
--- a/src/libxinevdec/Makefile.am
+++ b/src/libxinevdec/Makefile.am
@@ -13,8 +13,13 @@ if HAVE_GDK_PIXBUF
gdkpixbuf_module = xineplug_decode_gdk_pixbuf.la
endif
+if HAVE_THEORA
+theora_module = xineplug_decode_theora.la
+endif
+
xineplug_LTLIBRARIES = $(image_module) \
$(gdkpixbuf_module) \
+ $(theora_module) \
xineplug_decode_bitplane.la \
xineplug_decode_rgb.la \
xineplug_decode_yuv.la
@@ -36,3 +41,6 @@ xineplug_decode_gdk_pixbuf_la_SOURCES = gdkpixbuf.c
xineplug_decode_gdk_pixbuf_la_CFLAGS = $(AM_CFLAGS) $(GDK_PIXBUF_CFLAGS)
xineplug_decode_gdk_pixbuf_la_LIBADD = $(XINE_LIB) $(DYNAMIC_LD_LIBS) $(GDK_PIXBUF_LIBS)
+xineplug_decode_theora_la_SOURCES = xine_theora_decoder.c
+xineplug_decode_theora_la_CFLAGS = $(AM_CFLAGS) $(OGG_CFLAGS) $(THEORA_CFLAGS)
+xineplug_decode_theora_la_LIBADD = $(XINE_LIB) $(OGG_LIBS) $(THEORA_LIBS)