summaryrefslogtreecommitdiff
path: root/src/post/deinterlace/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/post/deinterlace/plugins/Makefile.am')
-rw-r--r--src/post/deinterlace/plugins/Makefile.am40
1 files changed, 20 insertions, 20 deletions
diff --git a/src/post/deinterlace/plugins/Makefile.am b/src/post/deinterlace/plugins/Makefile.am
index c04c3b7b2..4185b5706 100644
--- a/src/post/deinterlace/plugins/Makefile.am
+++ b/src/post/deinterlace/plugins/Makefile.am
@@ -17,6 +17,11 @@ include $(top_srcdir)/misc/Makefile.common
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# libpostproc is here so we can use their nice mangle.h
+AM_CFLAGS = $(VISIBILITY_FLAG)
+AM_CPPFLAGS = -I$(top_srcdir)/src/post/deinterlace \
+ -I$(top_srcdir)/contrib/ffmpeg/libpostproc
+
EXTRA_DIST = greedy2frame_template.c greedyh.asm \
tomsmocomp/SearchLoop0A.inc tomsmocomp/SearchLoopBottom.inc \
tomsmocomp/SearchLoopEdgeA.inc tomsmocomp/SearchLoopEdgeA8.inc \
@@ -30,29 +35,24 @@ EXTRA_DIST = greedy2frame_template.c greedyh.asm \
noinst_HEADERS = plugins.h greedyhmacros.h
-# libpostproc is here so we can use their nice mangle.h
-AM_CFLAGS = $(VISIBILITY_FLAG)
-AM_CPPFLAGS = -I$(top_srcdir)/src/post/deinterlace \
- -I$(top_srcdir)/contrib/ffmpeg/libpostproc
+if DEBUG_BUILD
+debug_sources = greedy2frame.c
+nodebug_sources =
+else
+debug_sources =
+nodebug_sources = greedy2frame.c
+endif
# per-object CFLAGS -- drop optimization on kdetv_greedyh.c so that gcc
# doesn't run out of general registers trying to compile it.
noinst_LTLIBRARIES = libdeinterlacepluginsO1.la libdeinterlaceplugins.la
-
-libdeinterlacepluginsO1_la_SOURCES = kdetv_greedyh.c
-libdeinterlacepluginsO1_la_CFLAGS = $(AM_CFLAGS) $(O1_CFLAGS)
-
-libdeinterlaceplugins_la_SOURCES = \
- double.c \
- greedy.c \
- linear.c \
- linearblend.c \
- vfir.c \
- weave.c \
- greedy2frame.c \
- scalerbob.c \
- kdetv_tomsmocomp.c
-libdeinterlaceplugins_la_LIBADD = libdeinterlacepluginsO1.la $(XINE_LIB)
-libdeinterlaceplugins_la_CFLAGS = $(AM_CFLAGS) $(DEFAULT_OCFLAGS)
+libdeinterlacepluginsO1_la_SOURCES = kdetv_greedyh.c $(debug_sources)
+libdeinterlacepluginsO1_la_CFLAGS = $(O1_CFLAGS) $(AM_CFLAGS)
+
+libdeinterlaceplugins_la_SOURCES = double.c greedy.c linear.c linearblend.c \
+ vfir.c weave.c scalerbob.c kdetv_tomsmocomp.c \
+ $(nodebug_sources)
+libdeinterlaceplugins_la_LIBADD = $(XINE_LIB) libdeinterlacepluginsO1.la
+libdeinterlaceplugins_la_CFLAGS = $(DEFAULT_OCFLAGS) $(AM_CFLAGS)
libdeinterlaceplugins_la_LDFLAGS = $(AM_LDFLAGS) $(xineplug_ldflags)