summaryrefslogtreecommitdiff
path: root/src/post/goom/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/post/goom/Makefile.am')
-rw-r--r--src/post/goom/Makefile.am51
1 files changed, 23 insertions, 28 deletions
diff --git a/src/post/goom/Makefile.am b/src/post/goom/Makefile.am
index 41a5eb7ae..4b6fe9862 100644
--- a/src/post/goom/Makefile.am
+++ b/src/post/goom/Makefile.am
@@ -1,40 +1,35 @@
include $(top_srcdir)/misc/Makefile.common
-EXTRA_DIST = zoom_filter_mmx.c zoom_filter_xmmx.c ppc_zoom_ultimate.s
-
libdir = $(XINE_PLUGINDIR)/post
+EXTRA_DIST = mmx.c xmmx.c ppc_drawings.s ppc_zoom_ultimate.s
+
+## -fomit-frame-pointer segfaults here
+CFLAGS = `echo @CFLAGS@ | sed -e 's/-fomit-frame-pointer//g;s/-Os//g'`
+
lib_LTLIBRARIES = xineplug_post_goom.la
-if PPC_ARCH
-## DON T WORK extra_files = ppc_zoom_ultimate.s
-else
-## only compile if MMX is supported.
+## doesn't work
+#if PPC_ARCH
+#extra_files = ppc_drawings.s ppc_zoom_ultimate.s
+#AM_CPPFLAGS = -DCPU_POWERPC
+#endif
+
if HAVE_FFMMX
-extra_files = zoom_filter_mmx.c zoom_filter_xmmx.c
-MMX_CFLAG = -DHAVE_MMX
+extra_files = mmx.c xmmx.c
+AM_CPPFLAGS = -DHAVE_MMX
endif
-endif
-
-## -fomit-frame-pointer segfaults here
-CFLAGS = $(MMX_CFLAG) `echo @CFLAGS@ | sed -e 's/-fomit-frame-pointer//g;s/-Os//g'`
xineplug_post_goom_la_SOURCES = $(extra_files) xine_goom.c \
- goom_core.c \
- filters.c \
- lines.c \
- ifs_display.c \
- ifs.c \
- graphic.c \
- gfontlib.c \
- gfontrle.c \
- surf3d.c \
- surface.c \
- tentacle3d.c
-
+ config_param.c convolve_fx.c cpu_info.c drawmethods.c filters.c flying_stars_fx.c \
+ gfontlib.c gfontrle.c goom_core.c goom_hash.c goom_script.c goom_script_scanner.c \
+ goom_script_scanner.tab.c goom_tools.c graphic.c ifs.c lines.c mathtools.c \
+ plugin_info.c sound_tester.c surf3d.c tentacle3d.c v3d.c
xineplug_post_goom_la_LIBADD = $(XINE_LIB)
-xineplug_post_goom_la_LDFLAGS = -avoid-version -module @XINE_PLUGIN_MIN_SYMS@
+xineplug_post_goom_la_LDFLAGS = -avoid-version -module $(XINE_PLUGIN_MIN_SYMS)
-noinst_HEADERS = drawmethods.h goom_config.h graphic.h mathtools.h surface.h xmmx.h \
- filters.h goom_core.h ifs.h mmx.h tentacle3d.h zoom_filter_mmx.h gfontlib.h \
- goom_tools.h lines.h surf3d.h v3d.h
+noinst_HEADERS = cpu_info.h default_scripts.h drawmethods.h gfontlib.h gfontrle.h goom.h \
+ goom_config.h goom_config_param.h goom_filters.h goom_fx.h goom_graphic.h goom_hash.h \
+ goom_plugin_info.h goom_script.h goom_script_scanner.h goom_script_scanner.tab.h \
+ goom_tools.h goom_typedefs.h goom_visual_fx.h ifs.h lines.h mathtools.h mmx.h \
+ ppc_drawings.h ppc_zoom_ultimate.h sound_tester.h surf3d.h tentacle3d.h v3d.h