summaryrefslogtreecommitdiff
path: root/src/vdr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/vdr/Makefile.am')
-rw-r--r--src/vdr/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/vdr/Makefile.am b/src/vdr/Makefile.am
new file mode 100644
index 000000000..68e6cd822
--- /dev/null
+++ b/src/vdr/Makefile.am
@@ -0,0 +1,14 @@
+include $(top_srcdir)/misc/Makefile.quiet
+include $(top_builddir)/misc/Makefile.plugins
+include $(top_srcdir)/misc/Makefile.common
+
+AM_CFLAGS = $(DEFAULT_OCFLAGS) $(VISIBILITY_FLAG)
+AM_LDFLAGS = $(xineplug_ldflags)
+
+if ENABLE_VDR
+xineplug_LTLIBRARIES = xineplug_vdr.la
+endif
+
+xineplug_vdr_la_SOURCES = combined_vdr.c combined_vdr.h input_vdr.c post_vdr_video.c post_vdr_audio.c
+xineplug_vdr_la_CFLAGS = $(AM_CFLAGS) -fno-strict-aliasing
+xineplug_vdr_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS)