summaryrefslogtreecommitdiff
path: root/src/video_dec/libmpeg2new/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/video_dec/libmpeg2new/Makefile.am')
-rw-r--r--src/video_dec/libmpeg2new/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/video_dec/libmpeg2new/Makefile.am b/src/video_dec/libmpeg2new/Makefile.am
new file mode 100644
index 000000000..bc322169d
--- /dev/null
+++ b/src/video_dec/libmpeg2new/Makefile.am
@@ -0,0 +1,14 @@
+include $(top_srcdir)/misc/Makefile.common
+
+AM_CFLAGS = $(DEFAULT_OCFLAGS) $(VISIBILITY_FLAG)
+AM_LDFLAGS = $(xineplug_ldflags)
+
+SUBDIRS = include libmpeg2
+
+xineplug_LTLIBRARIES = xineplug_decode_mpeg2new.la
+
+xineplug_decode_mpeg2new_la_SOURCES = \
+ xine_mpeg2new_decoder.c
+
+xineplug_decode_mpeg2new_la_LIBADD = $(XINE_LIB) libmpeg2/libmpeg2.la
+xineplug_decode_mpeg2new_la_CFLAGS = $(AM_CFLAGS) $(MLIB_CFLAGS)