summaryrefslogtreecommitdiff
path: root/win32/contrib/pthreads/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'win32/contrib/pthreads/configure.in')
-rw-r--r--win32/contrib/pthreads/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/win32/contrib/pthreads/configure.in b/win32/contrib/pthreads/configure.in
new file mode 100644
index 000000000..f5ea117f2
--- /dev/null
+++ b/win32/contrib/pthreads/configure.in
@@ -0,0 +1,23 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(pthread.h)
+AC_CANONICAL_HOST
+AC_CONFIG_HEADER(config.h)
+AC_PROG_CC
+
+dnl Abort here if there is no windows.h
+AC_CHECK_HEADER([windows.h],,AC_MSG_ERROR([Target system must be Win32]))
+
+AC_CHECK_HEADER([signal.h],signal_h=yes,)
+if test x$signal_h = xyes
+then
+ AC_CACHE_CHECK([for sigset_t], p32_cv_sigset_t,
+ AC_TRY_COMPILE([#include <signal.h>], [sigset_t x;],
+ p32_cv_sigset_t=yes, p32_cv_sigset_t=no))
+
+ if test x$p32_cv_sigset_t = xyes ; then
+ AC_DEFINE(HAVE_SIGSET_T)
+ fi
+fi
+
+AC_OUTPUT(GNUmakefile)