summaryrefslogtreecommitdiff
path: root/gentoo/vdr-vdrmanager-0.12.ebuild
diff options
context:
space:
mode:
authorbju <bju@maxi.fritz.box>2014-01-23 22:05:58 +0100
committerbju <bju@maxi.fritz.box>2014-01-23 22:05:58 +0100
commitb58cae86e52d1f34c8e007e04f2dbc28650d8789 (patch)
tree2fd8c5739f7ab4f76279a61dec6539a8532b486d /gentoo/vdr-vdrmanager-0.12.ebuild
parent612e0e00b8d55b70d4b83d13fc75e7ddd78d2b58 (diff)
downloadvdr-manager-b58cae86e52d1f34c8e007e04f2dbc28650d8789.tar.gz
vdr-manager-b58cae86e52d1f34c8e007e04f2dbc28650d8789.tar.bz2
- Giving VDRMANAGER_USE_{SSL,GZIP,ZLIB}=0 (default is 1) to the make call
SSL support and the compression methods can be disabled. This eliminates the compile time and also the runtime dependencies. - The Gentoo ebuils uses the USE flags "ssl", "gzip" and "zlib" to control the SSL and compress features.
Diffstat (limited to 'gentoo/vdr-vdrmanager-0.12.ebuild')
-rw-r--r--gentoo/vdr-vdrmanager-0.12.ebuild29
1 files changed, 23 insertions, 6 deletions
diff --git a/gentoo/vdr-vdrmanager-0.12.ebuild b/gentoo/vdr-vdrmanager-0.12.ebuild
index 8f4bc4a..b05c5c8 100644
--- a/gentoo/vdr-vdrmanager-0.12.ebuild
+++ b/gentoo/vdr-vdrmanager-0.12.ebuild
@@ -15,13 +15,14 @@ SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tar.gz"
KEYWORDS="~x86 ~amd64"
SLOT="0"
LICENSE="GPL-2"
-IUSE="-stream"
+IUSE="-stream +ssl +zlib -gzip"
DEPEND=">=media-video/vdr-2
- dev-libs/openssl
- sys-libs/zlib
- app-arch/gzip"
-RDEPEND="stream? ( media-plugins/vdr-streamdev[server] )"
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="stream? ( media-plugins/vdr-streamdev[server] )
+ gzip? ( app-arch/gzip )
+ $DEPEND"
VDRMANAGER_SSL_KEY_DIR="/etc/vdr/plugins/vdrmanager"
VDRMANAGER_SSL_KEY_FILE="${VDRMANAGER_SSL_KEY_DIR}/vdrmanager"
@@ -48,12 +49,21 @@ make_vdrmanager_cert() {
fperms 600 "${ROOT}${VDRMANAGER_SSL_KEY_FILE}.pem"
}
+src_prepare() {
+
+ use ssl || BUILD_PARAMS="$BUILD_PARAMS VDRMANAGER_USE_SSL=0"
+ use gzip || BUILD_PARAMS="$BUILD_PARAMS VDRMANAGER_USE_GZIP=0"
+ use zlib || BUILD_PARAMS="$BUILD_PARAMS VDRMANAGER_USE_ZLIB=0"
+
+ vdr-plugin-2_src_prepare
+}
+
pkg_postinst() {
vdr-plugin-2_pkg_postinst
einfo "Add a password to /etc/conf.d/vdr.vdrmanager"
- if use ssl ; then
+ if use ssl; then
if path_exists -a "${ROOT}${VDRMANAGER_SSL_KEY_FILE}.pem"; then
einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
einfo "emerge --config ${PN}"
@@ -61,6 +71,13 @@ pkg_postinst() {
einfo "No SSL cert found, creating a default one now"
make_vdrmanager_cert
fi
+ einfo
+ fi
+
+ if use gzip; then
+ einfo 'The plugin was installed with USE flag "gzip" set.'
+ einfo 'You must install app-arch/gzip to use the gzip'
+ einfo 'compression method.'
fi
}