summaryrefslogtreecommitdiff
path: root/vdr-vdrmanager/debian/rules
diff options
context:
space:
mode:
authorroot <root@vdr.(none)>2011-10-24 22:48:18 +0200
committerroot <root@vdr.(none)>2011-10-24 22:48:18 +0200
commitb670f01fd4da6e33eebc1fa7cb31dc0c7573dec3 (patch)
tree281e276b4ddcbf2185d040abf81ad3d3963f56f8 /vdr-vdrmanager/debian/rules
parentc431f3f6ed63194c44387982606a208757375285 (diff)
downloadvdr-manager-b670f01fd4da6e33eebc1fa7cb31dc0c7573dec3.tar.gz
vdr-manager-b670f01fd4da6e33eebc1fa7cb31dc0c7573dec3.tar.bz2
wigth folder
Diffstat (limited to 'vdr-vdrmanager/debian/rules')
-rwxr-xr-xvdr-vdrmanager/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/vdr-vdrmanager/debian/rules b/vdr-vdrmanager/debian/rules
new file mode 100755
index 0000000..2e942e5
--- /dev/null
+++ b/vdr-vdrmanager/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+# include /usr/share/cdbs/1/rules/dpatch.mk
+
+DEB_INSTALL_CHANGELOGS_ALL = HISTORY
+
+MAKE_OPTIONS = DVBDIR=/usr VDRDIR=/usr/include/vdr LIBDIR=. \
+ LOCALEDIR=debian/tmp/usr/share/locale
+
+common-build-arch::
+ $(MAKE) all $(MAKE_OPTIONS)
+
+cleanbuilddir::
+ $(MAKE) -o .dependencies clean $(MAKE_OPTIONS)
+ rm -f libvdr-*.so.*
+
+common-binary-predeb-arch::
+ sh /usr/share/vdr-dev/dependencies.sh