summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDieter Hametner <dh (plus) vdr (at) gekrumbel (dot) de>2008-01-06 23:40:26 +0100
committerDieter Hametner <dh (plus) vdr (at) gekrumbel (dot) de>2008-01-06 23:40:26 +0100
commit6249ff002f9388fafd464b461658a1f56c13defc (patch)
treea7156f8d41771bb3eb7c973dd9733b6f4cee67cd /debian/rules
parent87dae1589f9ed94b46aab1a7f0daed0d194b3b46 (diff)
downloadvdr-plugin-live-6249ff002f9388fafd464b461658a1f56c13defc.tar.gz
vdr-plugin-live-6249ff002f9388fafd464b461658a1f56c13defc.tar.bz2
Added debian build directory and some git specific files.
This was needed after the import of the cvs repository into a git repository.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules94
1 files changed, 94 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fc7104f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,94 @@
+#! /bin/sh /usr/share/vdr-dev/make-special-vdr.sh
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+# To use dpatch uncomment the following line and set Build-Depends to dpatch
+DPATCH=yes
+
+ifdef DPATCH
+include /usr/share/dpatch/dpatch.make
+else
+patch:
+patch-stamp:
+unpatch:
+endif
+
+MAKE_OPTIONS = DVBDIR=/usr VDRDIR=/usr/include/vdr LIBDIR=.
+
+configure: configure-stamp
+configure-stamp: patch-stamp
+ dh_testdir
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ $(MAKE) all $(MAKE_OPTIONS)
+ touch build-stamp
+
+clean: clean-patched unpatch
+clean-patched:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ -$(MAKE) -o .dependencies clean $(MAKE_OPTIONS)
+ rm -f libvdr-*.so.*
+ rm -rf locale
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_install
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+# dh_installdebconf
+ dh_installdocs
+ dh_installexamples
+# dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installman
+# dh_installinfo
+# dh_undocumented
+ dh_installchangelogs HISTORY
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ sh /usr/share/vdr-dev/patchlevel.sh subst
+ sh /usr/share/vdr-dev/dependencies.sh
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure \
+ clean-patched patch unpatch