summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/90_clean.dpatch16
2 files changed, 17 insertions, 0 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
new file mode 100644
index 0000000..1412cf0
--- /dev/null
+++ b/debian/patches/00list
@@ -0,0 +1 @@
+#90_clean
diff --git a/debian/patches/90_clean.dpatch b/debian/patches/90_clean.dpatch
new file mode 100755
index 0000000..a6dea38
--- /dev/null
+++ b/debian/patches/90_clean.dpatch
@@ -0,0 +1,16 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+
+## 99_clean.dpatch - Tobias Grimm <tg@e-tobi.nez>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fixes clean target
+
+@DPATCH@
+--- vdr-plugin-live-0.1.0.orig/pages/Makefile
++++ vdr-plugin-live-0.1.0/pages/Makefile
+@@ -53,4 +53,4 @@
+ $(AR) r $@ $^
+
+ clean:
+- @rm -f *~ *.o core* libpages.a $(OBJS:%.o=%.cpp)
++ @rm -f *~ *.o core* libpages.a $(OBJS:%.o=%.cpp) $(DEPFILE)