summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2012-07-01 20:15:45 +0200
committerMartin Dummer <martin.dummer@gmx.net>2012-07-01 20:15:45 +0200
commit28498899a405329e3c8c8fc9af5d573d1d2f923e (patch)
treef7736f603c1a8281353dec79e77a269dc207eb4b /debian
downloadvdr-plugin-playlist-0.0.2rc3.tar.gz
vdr-plugin-playlist-0.0.2rc3.tar.bz2
Initial import of version 0.0.2rc3v0.0.2rc3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/control12
-rw-r--r--debian/copyright8
-rw-r--r--debian/dirs1
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules79
6 files changed, 112 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..4416d09
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+vdr-plugin-playlist (0.0.2-1) unstable; urgency=low
+
+ * Bug fixes
+ -
+
+ -- Hardy Flor <HFlor@gmx.de> Fri, 08 Okt 2004 02:34:00 +0200
+vdr-plugin-playlist (0.0.1-1) unstable; urgency=low
+
+ * Initial revision
+
+ -- Hardy Flor <HFlor@gmx.de> Thu, 23 Sep 2004 23:42:32 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a124ccd
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: vdr-plugin-playlist
+Section: misc
+Priority: extra
+Maintainer: Hardy Flor <HFlor@gmx.de>
+Build-Depends: debhelper (>> 3.0.0), vdr-dev (>= 1.2.6-5)
+Standards-Version: 3.5.2
+
+Package: vdr-plugin-playlist
+Architecture: i386
+Depends: ${shlibs:Depends}, vdr (>= 1.2.6-5)
+Description: Plugin for VDR to display playlist for recordings
+ Patchlevel: ${patchlevel} \ No newline at end of file
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6e5458d
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,8 @@
+This package was debianized by Hardy Flor on Thu, 23 Sep 2004 23:42:32 +0200.
+
+Copyright:
+
+ You are free to distribute this software under the terms of
+ the GNU General Public License.
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in /usr/share/common-licenses/GPL file.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..aa338f5
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+usr/lib/vdr/plugins
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..20fd2fe
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=3
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ $(MAKE) all DVBDIR=/usr/include VDRDIR=/usr/include/vdr LIBDIR=. REMOTE=lirc
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ rm -f debian/vdr-plugin-playlist.substvars
+ rm -f libvdr-*.so*
+ make clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cp libvdr-playlist*.so.* $(CURDIR)/debian/vdr-plugin-playlist/usr/lib/vdr/plugins/
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+ dh_installcron
+ dh_installman
+ dh_installinfo
+ dh_installchangelogs HISTORY
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ cd debian; mv vdr-plugin-playlist.substvars substvars.old; cat /usr/include/vdr/patchlevel substvars.old > vdr-plugin-playlist.substvars; rm -f substvars.old
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure