summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-03-22 18:21:16 +0000
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-03-22 18:21:16 +0000
commit17a17afd5835c29cc8da396771278f2ead31e8fe (patch)
tree4ffd7775bda7bf1a04c2020b28c220cf9b524d11 /configure.ac
parent63f41055e2031631c01aee2539fa1a6027513078 (diff)
downloadxine-lib-17a17afd5835c29cc8da396771278f2ead31e8fe.tar.gz
xine-lib-17a17afd5835c29cc8da396771278f2ead31e8fe.tar.bz2
Try to reorganize the first tests so that the conditional macros are tested together, and that the programs are checked. This way all the compilers and flags variables are grouped together on the --help output.
CVS patchset: 8738 CVS date: 2007/03/22 18:21:16
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 18 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 5fb30ee99..7375beb81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,13 +92,6 @@ AM_INIT_AUTOMAKE("xine-lib", $SPEC_VERSION)
dnl AM_INIT_AUTOMAKE("xine-lib", $XINE_MAJOR-$XINE_PRE)
dnl ---------------------------------------------
-dnl Requirements for macros whose first invocations are conditional
-dnl ---------------------------------------------
-
-PKG_PROG_PKG_CONFIG
-
-
-dnl ---------------------------------------------
dnl Made possible to build for another arch.
dnl ---------------------------------------------
@@ -117,16 +110,24 @@ dnl ---------------------------------------------
dnl Check for programs.
dnl ---------------------------------------------
+AC_PROG_CC
+AM_PROG_AS
+case "$host_os" in
+ *darwin*)
+ AC_PROG_OBJC
+ ;;
+esac
+
AC_GNU_SOURCE
dnl Save CFLAGS, AC_ISC_POSIX set some unwanted default CFLAGS
saved_CFLAGS="$CFLAGS"
AC_ISC_POSIX
AC_PATH_MAGIC
CFLAGS="$saved_CFLAGS"
-AC_PROG_CC
AC_HEADER_STDC
+
AC_PROG_MAKE_SET
-dnl AC_PROG_EGREP needs autoconf 2.54, just hardcode for "egrep"
+AC_PROG_EGREP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_AWK
@@ -134,16 +135,6 @@ AC_C_INLINE
AC_CHECK_TOOL([STRINGS], [strings], [false])
-dnl We need to check this beforehand or autoconf bails out as we have it conditional.
-CC_CHECK_WERROR
-
-dnl ---------------------------------------------
-dnl Check for assembler (ffmpeg need it), don't call this before LIBTOOL
-dnl ---------------------------------------------
-
-AM_PROG_AS
-
-
dnl ---------------------------------------------
dnl Libtool
dnl ---------------------------------------------
@@ -166,6 +157,13 @@ AC_SUBST(STATIC)
dnl ---------------------------------------------
+dnl Requirements for macros whose first invocations are conditional
+dnl ---------------------------------------------
+
+PKG_PROG_PKG_CONFIG
+CC_CHECK_WERROR
+
+dnl ---------------------------------------------
dnl NLS Support
dnl ---------------------------------------------
@@ -200,8 +198,6 @@ dnl Checks for typedefs, structures, and compiler characteristics.
dnl ---------------------------------------------
AC_C_BIGENDIAN
-dnl AC_C_BIGENDIAN triggers an AC_TRY_RUN warning; we can't cross compile
-dnl xine (oh, well)
AC_C_CONST
dnl AC_C_ALWAYS_INLINE removal allows ffmpeg to be more widely buildable
AC_TYPE_OFF_T
@@ -2346,11 +2342,9 @@ AM_CONDITIONAL(HAVE_MMX, test "x$arch_x86" = "xyes")
case $host_os in
darwin*)
- AC_PROG_OBJC
HOST_OS_DARWIN=1
AC_DEFINE_UNQUOTED(HOST_OS_DARWIN, 1, [Define this if built on Mac OS X/Darwin])
- OBJCFLAGS="-D_INTL_REDIRECT_MACROS $CFLAGS $OBJCFLAGS"
- AC_SUBST(OBJCFLAGS)
+ OBJCFLAGS="-D_INTL_REDIRECT_MACROS $OBJCFLAGS"
;;
esac
AM_CONDITIONAL(HOST_OS_DARWIN, test "x$HOST_OS_DARWIN" = "x1")