summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-18 17:52:13 +0200
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-18 17:52:13 +0200
commit1ae85c23560a870d34edaafd76b2cb64b9b95c93 (patch)
tree078c431dd8cc4b435ab3182196b4bd836d0edb0c /configure.ac
parent1b589783e8f1bf896a4dc8fdcdfe854e37a57270 (diff)
downloadxine-lib-1ae85c23560a870d34edaafd76b2cb64b9b95c93.tar.gz
xine-lib-1ae85c23560a870d34edaafd76b2cb64b9b95c93.tar.bz2
Replace libdts 0.0.2 with libdca 0.0.5 and contextually move it in contrib/.
libdca 0.0.5 was released about a week ago, and this commit replaces the old code from libdts 0.0.2 (that was renamed libdca). There's basically no functional change even if the build system is simplified as configure takes care of switching between the two implementations on its own.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c4799d04e..8436f7a43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1914,7 +1914,7 @@ dnl ---------------------------------------------
AC_ARG_ENABLE(dts, AS_HELP_STRING([--disable-dts], [Disable support for DTS decoding library (default: enabled)]),
[enable_libdts="$enableval"], [enable_libdts="yes"])
-AC_ARG_WITH(external-libdts, AS_HELP_STRING([--with-external-libdts], [use external libdts library (not recommended)]),
+AC_ARG_WITH(external-libdts, AS_HELP_STRING([--with-external-libdts], [use external libdts/libdca library (not recommended)]),
[external_libdts="$withval"], [external_libdts="no"])
have_dts="no"
@@ -1923,16 +1923,20 @@ if test "x$enable_libdts" = "xno"; then
AC_MSG_RESULT([libdts support disabled])
elif test "x$external_libdts" = "xyes"; then
PKG_CHECK_MODULES(LIBDTS, [libdts], have_dts=yes, have_dts=no)
- AC_CHECK_HEADERS([dts.h])
- AC_SUBST(LIBDTS_LIBS)
- AC_SUBST(LIBDTS_CFLAGS)
if test "x$have_dts" = "xno"; then
AC_MSG_RESULT([*** no usable version of libdts found, using internal copy ***])
fi
else
AC_MSG_RESULT([Use included libdts support])
+ LIBDTS_CFLAGS='-I$(top_srcdir)/contrib/libdca'
+ LIBDTS_DEPS='$(top_builddir)/contrib/libdca/libdca.la'
+ LIBDTS_LIBS='$(top_builddir)/contrib/libdca/libdca.la'
fi
+AC_SUBST(LIBDTS_LIBS)
+AC_SUBST(LIBDTS_DEPS)
+AC_SUBST(LIBDTS_CFLAGS)
+
AM_CONDITIONAL(DTS, test "x$enable_libdts" = "xyes")
AM_CONDITIONAL(EXTERNAL_LIBDTS, test "x$have_dts" = "xyes")
@@ -2590,6 +2594,7 @@ doc/hackersguide/Makefile
doc/faq/Makefile
doc/Doxyfile
contrib/Makefile
+contrib/libdca/Makefile
contrib/libmpcdec/Makefile
contrib/libxdg-basedir/Makefile
include/Makefile