summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Pang <athp@users.sourceforge.net>2004-09-28 15:36:39 +0000
committerAndre Pang <athp@users.sourceforge.net>2004-09-28 15:36:39 +0000
commit1c59446b7a7b45d9014a5f43524af18bdb1c9341 (patch)
tree816d83efb5b400dab4244c48c482a9c4d8dadca5 /configure.ac
parentfadc00dfaef9800832cdd180eb5921c35a2cc60c (diff)
downloadxine-lib-1c59446b7a7b45d9014a5f43524af18bdb1c9341.tar.gz
xine-lib-1c59446b7a7b45d9014a5f43524af18bdb1c9341.tar.bz2
Turn #if condition in ppcasm_string.S to an AM_CONDITIONAL: fixes compilation
on Mac OS X. Thanks to kfish for the suggestion. CVS patchset: 7005 CVS date: 2004/09/28 15:36:39
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba0fa278b..8071d2a7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1621,6 +1621,7 @@ case "$host_or_hostalias" in
;;
*darwin*)
+ HOST_OS_DARWIN=1
AC_DEFINE_UNQUOTED(HOST_OS_DARWIN, 1, [Define this if built on Mac OS X/Darwin])
CFLAGS="-O3 -pipe -fomit-frame-pointer $m_wm $m_psb -fexpensive-optimizations $f_si $f_nsa -ffast-math -funroll-loops -finline-functions -no-cpp-precomp -D_INTL_REDIRECT_MACROS $CFLAGS"
DEBUG_CFLAGS="-O3 $DEBUG_CFLAGS"
@@ -1801,6 +1802,7 @@ case "$host_or_hostalias" in
;;
esac
+AM_CONDITIONAL(HOST_OS_DARWIN, test x"$HOST_OS_DARWIN" = "x1")
AM_CONDITIONAL(HAVE_W32DLL, test x"$enable_w32dll" = "xyes")
if test x"$enable_w32dll" = "xyes"; then