summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Torri <storri@users.sourceforge.net>2002-11-04 00:37:18 +0000
committerStephen Torri <storri@users.sourceforge.net>2002-11-04 00:37:18 +0000
commit2ebab9ec4a93cf17ab2c781425e13816f1af08e4 (patch)
tree02016987aeff6a3df31e0387020e559dc0e50b8d /configure.ac
parenta900108c25f7ad2c215ea563e8c92274b261666b (diff)
downloadxine-lib-2ebab9ec4a93cf17ab2c781425e13816f1af08e4.tar.gz
xine-lib-2ebab9ec4a93cf17ab2c781425e13816f1af08e4.tar.bz2
To build xine-lib now from cvs you run: autogen.sh
You would do: autogen.sh <configure flags> or autogen <shortcut> The short cuts are: aclocal - re-run aclocal autoheader - re-run autoheader automake - re-run automake autoconf - re-run aclocal AND autoconf libtoolize - re-run libtoolize noconfig - re-run all gnu tools without doing ./configure default - run ./configure with <configure flags> or none (if no flags are present) Removed cvscompile.sh and misc/autogen.sh (deprecated) General clean up install-debug for Makefile.am files. CVS patchset: 3180 CVS date: 2002/11/04 00:37:18
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 930a54a1a..eb1efc8b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -757,6 +757,9 @@ case "$host_or_hostalias" in
dnl special check for k7 cpu CC support
AC_TRY_CFLAGS("$sarchopt=athlon", k7cpu="athlon", k7cpu="i686")
+ AC_TRY_CFLAGS("-mmmx",f_mmmx="-mmmx", f_mmmx="")
+ AC_TRY_CFLAGS("-msse",f_msse="-msse", f_msse="")
+
dnl add x86 specific gcc CFLAGS
CFLAGS="$CFLAGS -O3 -pipe -fomit-frame-pointer $f_af $f_al $f_aj $m_wm $m_psb -fexpensive-optimizations $f_si $f_nsa -ffast-math -funroll-loops -finline-functions"
@@ -772,7 +775,9 @@ case "$host_or_hostalias" in
i486-*) # oh dear!
archopt_val="i486" ;;
i586-*)
- archopt_val="pentium" ;;
+ archopt_val="pentium"
+ CFLAGS="$CFLAGS $f_mmmx"
+ ;;
i686-*)
archopt_val="pentiumpro"
if test x"$check_athlon" = "xyes"; then
@@ -784,6 +789,7 @@ case "$host_or_hostalias" in
esac
fi
fi
+ CFLAGS="$CFLAGS $f_mmmx $f_msse"
;;
k6-*)
archopt_val="k6" ;;