summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2006-06-17 12:45:51 +0000
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2006-06-17 12:45:51 +0000
commit5817595983c62f616fb31a6d3f297d47a9b20519 (patch)
tree5bde7c8a9b50f81daf12790dc01c5d6480de9cd6 /configure.ac
parent48afd7769daf349aa921a94b1c0dffce3f8f228b (diff)
downloadxine-lib-5817595983c62f616fb31a6d3f297d47a9b20519.tar.gz
xine-lib-5817595983c62f616fb31a6d3f297d47a9b20519.tar.bz2
Fix Altivec libmpeg2 decoding, thanks to Luca Barbato (lu_zero@gentoo.org) and Christer Palm (palm@nogui.se).
CVS patchset: 8045 CVS date: 2006/06/17 12:45:51
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b89ec065d..f384150ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1989,6 +1989,8 @@ case "$host_or_hostalias" in
dnl _AM_DEPENDENCIES (below), and doing the AC_SUBST elicits a warning
dnl from automake 1.6.
+ AC_CHECK_HEADER([altivec.h], , enable_altivec=no)
+
if test x$enable_altivec = xyes; then
AC_DEFINE_UNQUOTED(ENABLE_ALTIVEC,,[Define this if you want to use altivec on PowerPC CPUs])
CFLAGS="$CFLAGS -faltivec"
@@ -2000,9 +2002,13 @@ case "$host_or_hostalias" in
AS="$CC"
AC_DEFINE_UNQUOTED(FPM_PPC,,[Define to select libmad fixed point arithmetic implementation])
AC_DEFINE_UNQUOTED(ARCH_PPC,,[Define this if you're running PowerPC architecture])
+
+ AC_CHECK_HEADER([altivec.h], , enable_altivec=no)
if test x$enable_altivec = xyes; then
AC_DEFINE_UNQUOTED(ENABLE_ALTIVEC,,[Define this if you have a Motorola 74xx CPU])
+ CFLAGS="$CFLAGS -maltivec"
+ LIBMPEG2_CFLAGS="$LIBMPEG2_CFLAGS -force_cpusubtype_ALL -maltivec"
fi
;;
sparc*-*-linux*)