summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-04 14:01:47 +0200
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-04 14:01:47 +0200
commit60a408c3446733dc752979c1eab579c25a4a4897 (patch)
treef897ecb51396ecf9f61c0f4219bf6f5a6287d380 /configure.ac
parent15d6933ee064a25f1b9753841fb87f261ea3e736 (diff)
parentbdbfc75de59531f8a4d8d85b7e0e58c95365cbd7 (diff)
downloadxine-lib-60a408c3446733dc752979c1eab579c25a4a4897.tar.gz
xine-lib-60a408c3446733dc752979c1eab579c25a4a4897.tar.bz2
Merge from main repo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index dc3663bf9..bd5ad93f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1618,6 +1618,12 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_RESULT($have_sunaudio)
AM_CONDITIONAL(HAVE_SUNAUDIO, test "x$have_sunaudio" = "xyes")
+if "x$have_sunaudio" = "xyes"; then
+ dnl NetBSD and OpenBSD don't have this, but check for it
+ dnl rather than assuming that it doesn't happen elsewhere.
+ AC_CHECK_MEMBERS([audio_info_t.output_muted])
+fi
+
dnl ---------------------------------------------
dnl IRIX style audio interface
@@ -1643,7 +1649,8 @@ dnl ---------------------------------------------
dnl cdrom ioctls
dnl ---------------------------------------------
-AC_CHECK_HEADERS(sys/cdio.h linux/cdrom.h)
+AC_CHECK_HEADERS([linux/cdrom.h sys/dvdio.h], [break])
+AC_CHECK_HEADERS([sys/cdio.h])
AM_CHECK_CDROM_IOCTLS(
[AC_DEFINE(HAVE_CDROM_IOCTLS,1,[Define this if you have CDROM ioctls])],
[AC_MSG_RESULT([*** (S)VCD support will be disabled ***])])
@@ -2859,9 +2866,6 @@ if test "x$enable_libmad" = "xyes"; then
echo " - MAD (MPG 1/2/3) (internal library)"
fi
fi
-if test "x$have_wavpack" = "xyes"; then
- echo " - wavpack"
-fi
if test "x$enable_libdts" = "xyes"; then
if test "x$have_dts" = "xyes"; then
echo " - DTS (external library)"