summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrantišek Dvořák <valtri@users.sourceforge.net>2004-01-01 18:14:51 +0000
committerFrantišek Dvořák <valtri@users.sourceforge.net>2004-01-01 18:14:51 +0000
commit6fc61879fcde8b512d5654588bc8daa2fb13128e (patch)
tree84c442c3905af9aa974d8179236b8f86a89e51bf /configure.ac
parent68651ae25728f746df6736cc7291179d60232315 (diff)
downloadxine-lib-6fc61879fcde8b512d5654588bc8daa2fb13128e.tar.gz
xine-lib-6fc61879fcde8b512d5654588bc8daa2fb13128e.tar.bz2
Win32 port, mainly DirectX:
* use DirectX under CygWin and basic auto-stuff * move some my macros in configure.ac * I don't know why, but shared directx plugins can't be linked with libdxguid.a. Used cute-hack, idea is from mplayer. Also thanks to hexedit, because I haven't sources of w32api. * Fix some warnings in vo directx and ao directx. * Decrease version of directx. It seems it still works. For compilation with DirectX under Cygwin you need header files from directx-sdk. Autoconf macros are only basic, but it works. for example: DIRECTX_CFLAGS=-I/cygrive/c/Program\ Files/Directx/include ./autogen.sh CVS patchset: 5971 CVS date: 2004/01/01 18:14:51
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 48 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b1f736313..8cdd63308 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,9 +163,6 @@ AC_TYPE_OFF_T
AC_TYPE_SIZE_T
dnl AC_CHECK_TYPES([ptrdiff_t])
AC_CHECK_GENERATE_INTTYPES([include])
-AC_CHECK_HEADERS(libgen.h)
-AC_CHECK_FUNCS(basename)
-AC_FUNC_FSEEKO
dnl ---------------------------------------------
@@ -652,6 +649,51 @@ AM_CONDITIONAL(HAVE_STK, [test x"$have_stk" = x"yes"])
dnl ---------------------------------------------
+dnl check for DirectX
+dnl ---------------------------------------------
+AC_MSG_CHECKING(for DirectX)
+DIRECTX_VIDEO_LIBS="$DIRECTX_LIBS -lgdi32 -lddraw"
+DIRECTX_AUDIO_LIBS="$DIRECTX_LIBS -ldsound"
+AC_LANG_SAVE()
+AC_LANG_C()
+ac_save_CFLAGS="$CFLAGS"
+ac_save_LIBS="$LIBS"
+CFLAGS="$CFLAGS $DIRECTX_CFLAGS"
+LIBS="$LIBS $DIRECTX_VIDEO_LIBS $DIRECTX_AUDIO_LIBS"
+AC_COMPILE_IFELSE(
+ [
+#include <stddef.h>
+
+#include <windows.h>
+#include <ddraw.h>
+#include <dsound.h>
+
+int main() {
+ DirectDrawCreate(0, NULL, 0);
+ DirectsoundCreate(0, NULL, 0);
+
+ return 0;
+}
+ ],
+ [have_directx=yes
+ AC_DEFINE(HAVE_DIRECTX,1,[Define this if you have DirectX])],,)
+CFLAGS=$ac_save_CFLAGS
+LIBS=$ac_save_LIBS
+AC_LANG_RESTORE()
+
+if test x$have_directx = xyes ; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(*** All DirectX dependent parts will be disabled ***)
+fi
+
+AC_SUBST(DIRECTX_CFLAGS)
+AC_SUBST(DIRECTX_AUDIO_LIBS)
+AC_SUBST(DIRECTX_VIDEO_LIBS)
+AM_CONDITIONAL(HAVE_DIRECTX, test x$have_directx = "xyes" )
+
+
+dnl ---------------------------------------------
dnl dxr3 / hollywood plus card
dnl ---------------------------------------------
@@ -1283,8 +1325,9 @@ dnl Some extra checks.
dnl ---------------------------------------------
AC_CHECK_LIB(posix4, sched_get_priority_min)
-AC_CHECK_FUNCS([vsscanf sigaction sigset getpwuid_r nanosleep strsep strpbrk setenv])
-AC_CHECK_HEADERS(byteswap.h malloc.h execinfo.h ucontext.h sys/mman.h sys/mixer.h)
+AC_CHECK_FUNCS([vsscanf sigaction sigset getpwuid_r nanosleep strsep strpbrk setenv basename])
+AC_FUNC_FSEEKO
+AC_CHECK_HEADERS(byteswap.h malloc.h execinfo.h ucontext.h sys/mman.h sys/mixer.h libgen.h)
if test "$GCC" = yes; then