summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrantišek Dvořák <valtri@users.sourceforge.net>2005-02-03 07:19:03 +0000
committerFrantišek Dvořák <valtri@users.sourceforge.net>2005-02-03 07:19:03 +0000
commit89c1c59fb83bc1d4598543b1bcaee5b69776b421 (patch)
tree8f8f88de29b540e4f21ed63a243c12288571fbef /configure.ac
parent00f8f557ae278bb0aa4dee3cb664e154d32a7ba3 (diff)
downloadxine-lib-89c1c59fb83bc1d4598543b1bcaee5b69776b421.tar.gz
xine-lib-89c1c59fb83bc1d4598543b1bcaee5b69776b421.tar.bz2
**BUGFIX**
Fixed build on solaris: - use libresolv in hstrerror check - replace PRIiMAX and PRIXMAX by PRIdMAX and PRIxMAX Removed timezone struct for MinGW from public os_types.h, update header comment. Fixed build musepack library on some platforms using xine types. Thanks to Niki W. Waibel for reporting and testing. CVS patchset: 7378 CVS date: 2005/02/03 07:19:03
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc0264d51..60637c56a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1514,7 +1514,20 @@ AC_CHECK_FUNCS([vsscanf sigaction sigset getpwuid_r nanosleep lstat memset strch
AC_FUNC_FSEEKO
AC_DEFINE(_GNU_SOURCE)
AC_CHECK_HEADERS(byteswap.h malloc.h execinfo.h ucontext.h sys/mman.h sys/mixer.h libgen.h netdb.h sys/times.h sys/ioctl.h)
-AC_REPLACE_FUNCS(basename gettimeofday hstrerror setenv strndup strpbrk strsep strtok_r)
+AC_REPLACE_FUNCS(basename gettimeofday setenv strndup strpbrk strsep strtok_r)
+
+AC_LIBSOURCE(hstrerror.c)
+AC_LINK_IFELSE([#include <netdb.h>
+int main(void) {
+ hstrerror(0);
+}], ac_cv_function_system_hstrerror="yes")
+AC_CHECK_LIB([resolv], [hstrerror], [ac_cv_function_system_hstrerror="yes"])
+if test x"$ac_cv_function_system_hstrerror" = "xyes"; then
+ AC_DEFINE(HAVE_HSTRERROR, 1, [Define to 1 if you have 'hstrerror' in <netdb.h>])
+else
+ AC_LIBOBJ(hstrerror)
+fi
+
AH_BOTTOM([/* include internal system specific header */
#include "os_internal.h"])