summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrantišek Dvořák <valtri@users.sourceforge.net>2004-09-26 22:54:51 +0000
committerFrantišek Dvořák <valtri@users.sourceforge.net>2004-09-26 22:54:51 +0000
commit9025bf7cc003e8e9981eaf2adc4c614d9bca765c (patch)
tree2788c21b13ec9bfb2fbf2852ae7b4a6c6b764979 /configure.ac
parentc4fcac1273c5be824b7468edcda160c38dec1692 (diff)
downloadxine-lib-9025bf7cc003e8e9981eaf2adc4c614d9bca765c.tar.gz
xine-lib-9025bf7cc003e8e9981eaf2adc4c614d9bca765c.tar.bz2
- almost finalize headers refactoring needed for MSVC frontends (and for other
poor platforms, of course) - fix a bug in generated xine-config for WIN32 and make it relocateable under Windows - MSVC port: update, fix some warnings, remove old unneeded files - improve function for getting runtime directory, it will need next fix yet (bug probably due to active volume drives) CVS patchset: 7001 CVS date: 2004/09/26 22:54:51
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5e90d0fc6..ba0fa278b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1870,13 +1870,15 @@ if test x"$SYS" = "xmingw32" -o x"$SYS" = "xcygwin"; then
eval XINE_FONTDIR="${bindir}/fonts"
eval XINE_LOCALEDIR="${bindir}/locale"
dnl directories from xine-config
- XINE_PLUGINPATH="\`basedir \$0\`/plugins"
- XINE_FONTPATH="\`basedir \$0\`/fonts"
- XINE_LOCALEPATH="\`basedir \$0\`/locale"
+ XINE_PLUGINPATH="\`dirname \$0\`/plugins"
+ XINE_FONTPATH="\`dirname \$0\`/fonts"
+ XINE_LOCALEPATH="\`dirname \$0\`/locale"
dnl runtime directories
AC_DEFINE(XINE_PLUGINDIR,[exec_path_append_subdir("plugins")],[Define this to plugins directory location])
AC_DEFINE(XINE_FONTDIR,[exec_path_append_subdir("fonts")],[Define this to osd fonts dir location])
AC_DEFINE(XINE_LOCALEDIR,[exec_path_append_subdir("locale")],[Path where catalog files will be.])
+ dnl prefix in xine-config
+ XINE_CONFIG_PREFIX="\`dirname \$0\`/.."
else
dnl installation directories
XINE_PLUGINDIR="$libdir/xine/plugins/$XINE_MAJOR.$XINE_MINOR.$XINE_SUB"
@@ -1890,7 +1892,10 @@ else
AC_DEFINE_UNQUOTED(XINE_PLUGINDIR,"$XINE_PLUGINPATH",[Define this to plugins directory location])
AC_DEFINE_UNQUOTED(XINE_FONTDIR,"$XINE_FONTPATH",[Define this to osd fonts dir location])
AC_DEFINE_UNQUOTED(XINE_LOCALEDIR, "$XINE_LOCALEPATH",[Path where catalog files will be.])
+ dnl prefix in xine-config
+ XINE_CONFIG_PREFIX="${prefix}"
fi
+AC_SUBST(XINE_CONFIG_PREFIX)
AC_SUBST(XINE_PLUGINPATH)
AC_SUBST(XINE_FONTPATH)
AC_SUBST(XINE_LOCALEPATH)